Block is working, but not inline

Trying the following $L = M\mathrm{diag}(\mathbf{1}^T M)^{-1}U,$

Once I save the macro, it disappears from the document, and buttons preview and save stop working.

Confluence 4.1.9

All settings are default except rendering is set to internal.

2 answers

1 accepted

0 votes
Accepted answer

This issue has been solved in LaTeX Math 1.7.1.

I accepted the answer. However, we had to develop our own plugin to handle latex markup.

Hello I've just seen your reply, and I am curious whether you managed to fix PDF export in your own plugin, cause LaTeX plugin v1.4 has an issue with it. Regards, Milan Stakic

Hi Milan, which problem have you been having with PDF export using LaTeX Math?

Hello Jason, Thank you for returning to this topic, promptly. As you may know, LaTeX plugin v1.4 ( from Andy Brook ) has a problem with PDF Export, so I was just curious about Anton's modification how they managed to get working with PDF for example. On the other hand, LaTeX Math plugin's PDF Export functionally working fine. But there I experienced problem with inline, as you may know I've already wrote to you about that. Regards, Milan Stakic

Hi Milan, There was some serious incompatibility with new API, so I just rewrote it from scratch. Unfortunately I can't share the source code, due to legal reason. But happy to help if you ask more specific questions. Our macros works in very similar way to Andy's one - it calls latex and dvipng. Plus I added caching using ao. The main difference is that I had to use new API. Regards Anton

Hello Anton, Thanks for reply. Is there any mail that I can wrote to you directly if possible. Since, you say new API have to be used, what are the import packages that I need to use. Is there any general docs available for this. I hope you can shed more details about PDF Export, since I am looking in source code of LaTeX ( provide by Andy from BitBucket ) and trying to understand the structure, where to add PDF Export support. Is it possible to send you and log file, just to see the error I've got, maybe you will figure it out where the problem is. Regards, Milan Stakic

Hello About PDF Export issue with LaTeX (stepston ), I think I found out where is the problem. Regards, Milan Stakic

Hi Milan, Sorry for late response. Feel free to contact me via latex at kozyr co if you still have any issues. Regards

I've seen that problem once before, but I have not been able to reproduce it in a test environment. It appeared to be something in the Confluence setup that caused some Confluence to send the wrong URL for the placeholder images to the editor. This causes the editor to hang as you have experienced. Specifically, the URL sent to the editor repeated the context an extra time, so that it started with DOMAINADDRESS/confluence/confluence/ instead of DOMAINADDRESS/confluence/. Please let me know if you still experience this or if you have any extra details that may be useful in finding the root of the problem.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 31, 2018 in Marketplace Apps

Marketplace Spotlight: Zephyr

Hello Atlassian Community! Each month, we run a series of Spotlights to highlight Marketplace vendors and apps that our team thinks this Community would find valuable. In last month's Spotlig...

330 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you