Bagdr won't install on Stash 1.3

Being a Stash-Newbie administrator I tried to install Badgr-plugin via plugin manager within stash (http://xxxx:7990/plugins/servlet/upm/marketplace).

Installation failed with following error:

Problem accessing plugin file at https://marketplace.atlassian.com/download/plugins/nl.stefankohler.stash.badgr/version/4.

What's going wrong? Any hint welcome

3 answers

1 accepted

1 vote
Accepted answer

Hi Johannes,

the URL should be

https://marketplace.atlassian.com/download/plugins/nl.stefankohler.stash.badgr/version/4

instead of

https://marketplace.atlassian.com/download/plugins/nl.stefankohler.stash.badgr/version/4.

(note the trailing dot that shouldn't be there).

For the former I get the same response, the latter should return a 302 that redirects to https://dl.dropbox.com/u/14703924/plugins.atlassian.com/nl.stefankohler.stash.badgr/badgr-1.3.jar and will download the jar.

Unfortunately it's hard to tell what exactly is going wrong without having a closer look at your log files.

Please open a support ticket at https://support.atlassian.com/browse/SSP including the log files with the plugin installation error so that we can help you fix this problem.

As a workaround you can install the plugin jar manually via the "Upload Plugin" link in the "Manage Plugins" section.

Hope this helps.

Cheers,

Stefan

Hi Stefan,

thanks a lot for your answer.

Damn - how could I oversee the trailing dot in my URL ....

Reading your answer the reason for failure is clear: it's a access problem. Since I'm sitting behind a firewall which blocks dropbox, it's obvious why it fails.

Thanks again - I have to talk to our IT department about this.

Johannes

0 votes

Hi,

I can successfully install the Badgr plugin using Stash 1.3.0 and Badgr 1.3.

Could it be a (temporar) connection problem?

Can you initiate a download if you request the https://marketplace.atlassian.com/download/plugins/nl.stefankohler.stash.badgr/version/4 URL (from the same machine)?

Cheers,

Stefan

Cannot imagine it's a temporary problem: I've been trying on several days now, but always failed with the same error. (and installing "Awesome Graphs for Stash"-plugin during the same period was successful ...)

Opening the URL https://marketplace.atlassian.com/download/plugins/nl.stefankohler.stash.badgr/version/4 within my browser leads to the following response:

Requesting "GET /plugins/nl.stefankohler.stash.badgr/version/4." on servlet "/download" but only have:

    GET /plugins/:key
    GET /plugins/:key/version/:buildNum

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 31, 2018 in Marketplace Apps

Marketplace Spotlight: Zephyr

Hello Atlassian Community! Each month, we run a series of Spotlights to highlight Marketplace vendors and apps that our team thinks this Community would find valuable. In last month's Spotlig...

344 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you