Atlassian Marketplace server is not reachable

[Pardon the duplicate with my previously posted question; I was attempting to submit a Support ticket, and clicked the "Display this question in Answers" setting.]

I recently downloaded and installed JIRA 5.1.3.

When I attempt to use UPM on the Plugins Page, the error banner reads: Atlassian Marketplace server is not reachable

With the help of a network admin at my company we have narrowed the issue down to a proxy problem.

We updated the Java options (in the JIRA properties dialog) to include the following properties:

  • -Dhttp.proxyHost=hlanproxy.rl.gov
  • -Dhttp.proxyPort=8080
  • -Dhttp.nonProxyHosts=localhost
  • -Dhttp.proxyUser=hanford jira1
  • -Dhttp.proxyPassword= ourpassword
  • -Dhttps.proxyHost=hlanproxy.rl.gov
  • -Dhttps.proxyPort=8080
  • -Dhttps.proxyUser=hanford jira1
  • -Dhttps.proxyPassword= ourpassword

The network admin now confirms that the page request is reaching the proxy, but not the credentials. Our proxy requires integrated authentication, so it is asking for credentials, but the application is not supplying them.

I tried adding the credentials to the conf/server.xml file but must have done so incorrectly because that broke it altogether (led to a 502 Proxy Error that prevented the whole page from loading). I updated the Connector element with the following attributes:

proxyName="hlanproxy.rl.gov"
proxyPort="8080"
proxyUser="hanford\jira1"
proxyPassword="[ourpassword]"

UPDATE: Here is the list of JIRA documentation pages that I have consulted:

Also, I have submitted a support ticket, but unfortunately the support personnel couldn't solve the problem ("not in their scope"), and referred me back here.

2 answers

0 votes

Hi Kevin,

UPM 2.7.2 had a bug regarding proxy. If you are using this version, please try updating it to the latest version manually (downloading it here) and uploading on JIRA UI.

Hope this helps,

Marcus Silveira

I installed what was (I assumed) the latest version of JIRA as of a few weeks ago (5.1.3), and it came packaged with UPM 2.1.5. I'm shocked to learn that JIRA was released with an internal component is so far behind the latest stable release!

Nevertheless, I'll go ahead and manually update it, as you suggest. I'm still not sure I have the java options (or the conf/server.xml file) configured correctly (the docs are so unclear and inconsistent in this matter), but your recommendation seems prudent. Thanks.

Well, I have updated to the latest version (2.7.3) but unfortunately the problem is unresolved. I'm afraid the issue lies with my jira configuration -- I am still not sure I have the java options (or the conf/server.xml file) configured correctly -- the docs are so unclear and inconsistent in this matter!Thanks anyway!

Sorry to hear that Kevin.

I'd advise you to open a ticket on Support.atlassian.com so you can get better help from Atlassian Support Engineers.

Unfortunately, I already did that and they said that "proxy configuration is out of their scope". They recommended that I post my question here! :o

0 votes

Kevin - did you try NTLM configuration? From https://confluence.atlassian.com/display/DOC/Configuring+Web+Proxy+Support+for+Confluence, it's the ISA piece:

-Dhttp.auth.ntlm.domain=MYDOMAIN

Looking around, I'm not seeing whether JIRA can handle that or not. We (Atlassian) need to update the guide for JIRA for how to configure an outbound proxy, and whether NTLM integrated authentication is supported or not. I'll look into that.

Are you using integrated authentication, and if so, does that syntax work?

Thanks for the suggestion. We are using integrated authentication, but unfortunately, adding that syntax to the Java options did not cure the problem. My IT admin informs me that he still does not see the credentials getting passed to the proxy. It's all anonymous.

I've raised this as a JIRA bug. Sorry, I'm afraid until we fix this in JIRA, you'll have to either download plugins manually (you can upload a JAR file from the server after downloading from a browser) or configure ISA proxy to allow an exception.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,412 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you