After marketplace upgrade, the modal still shows

As the modal shows "Please Migrate!", I followed the instructions.  I unsubscribed from the current plugin, then disabled it and finally uninstalled it.  I then went to the marketplace listing shown on the modal to install the new version.  After the install, I re-indexed JIRA Cloud, and I cleared all the cache in my browser and when I click My Work, I still see the same modal message - if I'm not supposed to click the "My Work" link in the navigation, then why does it install that nav lin?  What should I do?

3 answers

1 accepted

Volodymyr.. any update?

Hi Rob, Sorry, I did not get emails from the site. The license and the link are correct. Please make sure that there is only one entry for the Work Calendar when you go to Administration -> Addons -> Manage Addons. If there is old "my_work_calendar" entry it should be completely uninstalled. Just dissabling does not help. Please update me. I will contact Atlassian support, if there is only one "com.jiraworkcalendar.work-calendar" entry and the calendar is not shown,

Volodmyr, there is only 1 com.jiraworkcalendar.work-calendar, there is no other "my_work_calendar" entry it was completely uninstalled. Can you contact support about this?

Rob, reported the problem: https://ecosystem.atlassian.net/browse/AC-1749 Please check if I put the correct URL for your JIRA. Hope that Atlassian will be able to quickly help us.

Thanks for reporting Volodymyr, the URL for our instance is correct.

Could you please raise a JIRA Customer support ticket in order for us to assist you with the issue: https://support.atlassian.com/servicedesk/customer/portal/22

Hi Rob, While atlassian is doing their investigation I added additional logging on my server. Could you please try to click My Work menu and update me so I check the logs. This time probably you will get "License is inactive!" banner please ignore it.

Volodymyr, I just hit the "My Work" link 3 times in a row @ 8:27 AM PDT

Thank you Rob! Found your trails in the logs and update the support ticket.

Rob, guys from Atlassain found that "add-on user is not being granted application access" They granted the access on your instance. Please be aware that this user is NOT counted towards the license count. Details: https://support.atlassian.com/servicedesk/customer/portal/23/JST-161427 Please check if Work Calendar is loaded for you and update me.

It's working now!!! Thank you so much for your continued support!

Glad that we finally resolved it, thank you for your patience and cooperation!

Hi Volodymyr,

I enjoy Work Calendar - really sad it's not working right now.

I have successfully uninstalled the 'old' Work Calendar and had no work calendar installed on the system then installed from the marketplace link you provided in that modal box but I'm still getting the same error when clicking the "My Work" top navigation link.   I can't upload a screenshot either so here is the details when I open up the Work Calendar plugin:

Version: 1.2.1-AC

Vendor: Volodymyr Krupach

Add-on key: com.jiraworkcalendar.work-calendar

Licence details: Evaluation

License status: valid

and then our SEN number

 

When I click our top navigation link for "My Work" this is the URL that it goes to on our server:

https://(our server).atlassian.net/plugins/servlet/ac/com.jiraworkcalendar.work-calendar/calendar-page?project.key=(our key)&project.id=(our project id)

I removed information in the parenthesis ( ).  The above link seems to be referencing the new plug-in.  I've cleared my browser cache to make sure I wasn't visiting a cached page either.

Please help!

 

 

Hi Rob!

Thank you for using Work Calendar!

The only reason for getting the warning could be wrong version of Work Calendar. I wanted to attach screenshots illustrating step by  step uninstall and install but unfortunately screenshots upload is not working today sad. I requested contact with you through linkedIn and will be happy to send you screenshots I prepared if you give me your email.

To check that you have correct version please go to Administration -> Add-ons -> Manage add-ons and type "Work Calendar" into the filter box. This should show you all entries of Work Calendar that are installed on your instance. Please make sure that there is only one with "com.jiraworkcalendar.work-calendar" key.

If "com.jiraworkcalendar.work-calendar" is the only installed version and you still get the warning message instead of the calendar then it can mean that there is some problem with your instance and we will need to contact Atlassian support. I already had such strange situation when Work Calendar did not work for one particular customer.

Please update me.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

252 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you