It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"Structure Settings" - "Auto-switch to" seems not to work as expected. Why?

Lutz Rentel Oct 19, 2017

Dear ALM guys,

we are using Structure Add-on (version 4.2.0) with our Jira Server (version 7.4.2) and it is a real great help. Most questions around Structure we could get solved by ourselves by either reading the documentation or by playing around a bit.

But currently we are stuck with something, where we do not know, if it is an issue with Structure itself or if we just have some setting mistake.

We have several structure views available and usually each Jira issue is contained in at least one of these structures. By default the structure settings for the issue page are "Auto-switch to" enabled and "Structure with the displayed issue" is selected. So we would expect, that, when opening an issue, the structure view would automatically select the structure, this issue belongs to.

However, this does not work. The behavior for me (being Jira Administrator) and any of my team members is always, that the structure on the issue page is the last one opened by the user. So this is the behavior as if "Auto-switch" was DISabled.

What are we doing wrong?

2 answers

0 votes
Egor Tasa Oct 27, 2017

Hi Lutz,

The issue is most probably due to the structure being built by generators. Only issues added manually (or by synchronizers) can be detected by auto-switch. The reason for this is that to find a structure with the issue all generators in the system would have to be run on a regular basis, which would create a huge performance overhead. 

If however, the structures with manually added issues are not being selected, could you contact us via support@almworks.com with additional details?

Sorry for inconvenience,

Regards,
Egor Tasa
ALM Works Support

0 votes
Lutz Rentel Nov 16, 2017

Hi Egor,

sorry for not coming back sooner, but unfortunately I didn't get a notification that there was a reply to my question.

Now, yes, the structure/s in question are in fact created with automation and so this is seemingly "by design".

However we have modified a bit our way of working and currently only use one single main generic and automated structure in the whole company and have set this as the global default one. So usually everything now works fine.

Thank you very much for your efforts.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted in Marketplace Apps & Integrations

Demo Den Ep. 4: Continuous Integration with CircleCI & Jira Software

Get ready! Demo Den Episode 4 is coming your way on Tuesday, May 28, 2018 with a Continuous Integration and Delivery special demo. CircleCI Director of Solutions Engineering, Eddie Webb will show us ...

451 views 0 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you