Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Xray Jira: Is api for Xray updated in documentation?

Hi,

I'm using Xray for Jira, but I'm unable to use the api. Looking at the documentation:

https://confluence.xpand-it.com/display/public/XRAY/Pre-Conditions+-+REST

https://confluence.xpand-it.com/display/public/XRAY/Test+Sets+-+REST

 

If I use the next:

GET /rest/raven/1.0/api/precondition/{preConditionKey}/test

GET /rest/raven/1.0/api/testset/{testSetKey}/test

 

For both I'm getting: 404</status-code><message>null for uri

 

I've tested my credentials with the api from Jira and it works fine with it. Any ideas?

 

Regards.

1 answer

0 votes
Inês Silva
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jul 05, 2019

Hi Jose,

Yes. Our documentation is up to date regarding the Xray Rest API.
As this error message is not clear regarding the error you're getting, to understand the issue you're facing please contact us directly through our Support Service Desk. There we can ask you for some details and check together where the problem is.

Best regards,
Xray Team

I have tried to create a request but something's wrong with the application form that I can't create it, it returns an error message but doesn't say which field is incorrect or missing.

I'm using Jira Cloud, and for example to get the precondition, with the request like the one below:

http://****.atlassian.net/rest/raven/1.0/api/precondition/QT-324/test

 

I'm getting the next response:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<status>
<status-code>404</status-code>
<message>null for uri: https://****.atlassian.net/rest/raven/1.0/api/precondition/QT-324/test</message>
</status>

 

The Precondition does exist in: https://****.atlassian.net/browse/QT-324 and the host is correct because I use it with the Jira API without a problem.

 

Am I missing something?

Hi, 

I am also getting same error while using XRAY JIRA REST API for preconditions in JIRA Cloud. 

 

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<status>
    <status-code>404</status-code>
</status>
Please suggest if any solution.
Regards,
Dileep Kumar

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events