Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,238
Community Members
 
Community Events
176
Community Groups

Xray- Errors during testcase import

While importing(csv/json) the Test Results into XRAY Jira , we are getting error message "xray": "Test type not present".

Could any of you please provide detailed steps and configuration files on importing test cases with execution results.

 

 

1 answer

Hi @priyak 

This error happens when the imported file does not have the Test Type information. It is essential to have this information since the file can have different Test Types, so it is necessary to have a field that tells Xray the type of the test.
Please check our documentation for additional details:
https://docs.getxray.app/display/XRAYCLOUD/Importing+Tests+using+Test+Case+Importer#ImportingTestsusingTestCaseImporter-Preparingthesourcefile

This applies to both formats, CSV or JSON.

Any additional questions, please get in touch with Xray Support (http://Xraysupport.getXray.app); we would gladly assist you.

Thank you.

Kind regards,
Rogerio Paiva [Xray Support Team]

@Rogério Paiva - Xray Xporter I have tried to import 90+ test cases in which the test type field is only copied and pasted, but during import i am getting this error only for 3 fields

@esha_adhya it depends on the information that you have on those 3 fields (or rows).

If something is wrong with the value or with the format is not correctly followed.

It is best to contact Xray support (http://Xraysupport.getXray.app) so that we can test your file and find what is causing the error.

Thank you.

Kind regards,
Rogerio Paiva [Xray Support Team]

There appears to be a problem here.  When exporting from JIRA with the "all fields" option, "test type" isn't present in the CSV file as an option.  Defect perhaps?  Or are you suggesting the column be added manually and then populate accordingly?

Like Nadia Diachok likes this

Did this work for any one? I am getting the same error.

I'm trying to import one Test with multiple test steps. My CSV file looks similar to the example stated in the Xray Documentation: I have several rows, the Issue Id is always 1.

I'm getting the same error as stated above, when I only put the "test type" (manual in my case) in the first row. The error log says "xray": "Test type not present"

When I type the value in all of the rows, I can import my CSV file successfully, but then, Xray creates one Test per each row. Which is not what I want.

Did anyone have the same issues and has figured out a way to solve this?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS

Atlassian Community Events