Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,206
Community Members
 
Community Events
168
Community Groups

Xporter Conditional Statement not working

I have gone as far as copying and pasting from templates and exercises I have found for xporter. For the life of me I can't figure out why it isn't working.

My expected output to the code below should contain the date, but it does not.

_____________________________________________________________________________________ 

${Leave Type}

Copied If

#{if (%{'${Leave Type}'.equals('Accrued Annual Leave')})}

${dateformat("MM/dd/yyyy"):Begin}

#{end}

End Copied If

_______________________________________________________________________________________

Actual Output:

Accrued Annual Leave
Copied If
End Copied If

1 answer

Hi @Brian Karst 

Please look through your template and confirm if there isn't a minor error preventing the correct export of your mapping. If you turn the Paragraph Marks option from Word ON, you'll see that there are marks that Xporter won't interpret:

_thumb_106302.png

The pointed incorrect characters are a Word's replacement for spacing, and Xporter cannot interpret any of those correctly. Can you please replace them with the standard word spacing and retry?

Hope this helps! 

 

Best Regards, 

Sergio 

_____________

Solution Architect and Testing Advocate @Xray

Personal blog on testing, Agile, and software development: https://sergiofreire.com

Follow me on Twitter: https://twitter.com/darktelecom

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events