Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

XRay: New Test status is not showing up in the Test Plan progress bar

In XRay admin, I have created two new test status. 
[Fail-Expected] and [Fail-Flaky] (Purple and Pink status color)

I have updated the test status for some of the test cases.

 

In Test Execution, I can see it showing properly.
But in Test Plan, it is counting as "ToDo" 

*I have reindexed JIRA and it did not help


Can you please help?


Example below:
6 test cases in this test plan.
One pass, One fail, 1 Fail-Expected and 3 Fail-Flaky

  • Showing correctly in Test Execution
    image.png

 

 

  • Not showing correctly in Test Plan
  • 6 test cases in this test plan.
    One pass, One fail, rest are mapped to ToDo
  • image.png


  • In XRay admin, I have created two new test status. 
    [Fail-Expected] and [Fail-Flaky] (Purple and Pink status color)
  • image.png

2 answers

1 accepted

0 votes
Answer accepted

It is working now after our JIRA admin upgraded XRay from 3.6.1 to 4.1.6

Hi @Steven Chau ,

at first sight, your configuration seems OK and everything should work fine (which unfortunately is not the case). I've double-checked using similar names for the statuses but I was unable to replicate it.

One thing that you can try is to use the Integrity Checker to see if some problem arises.

Depending on the amount of data you have in your Jira instance, I would recommend doing that after hours. Usually, this doesn't take long unless you have millions of issues.

 

Nevertheless, I think it's best to reach out Xray support and provide any additional relevant information about your setup, and the team will be glad to help you out.

 

Regards

Sergio

=======================================

A personal blog on testing, Agile, and software development: https://sergiofreire.com

Follow me on Twitter: https://twitter.com/darktelecom

Thanks @Sergio Freire 

It is working now after our JIRA admin upgraded XRay from 3.6.1 to 4.1.6

Like Sergio Freire likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

New cloud apps roundup - June 2021

Since our last roundup in April, Atlassian's Marketplace Partners have added over 100 new cloud apps to the Atlassian Marketplace to help your teams work more efficiently. Let’s take a quick look a...

490 views 6 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you