Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,862
Community Members
 
Community Events
168
Community Groups

Why are no changes made after successful automation rule run?

I need to keep the Epic and Story in sync on a specific project, and have built a rule to automate these changes on issue edit.

 

When the rule runs, I can see it was successful and it shows the correct ticket ID's, but no changes are made? 

 

I've restricted this to update only 3 fields while I'm testing, but it's still not working.

 

Any ideas? What am I missing?

 

Here is the rule:

 

 

Capture.JPGCapture1.JPG

Here are the results: 

Capture3.JPG

 

 

1 answer

0 votes
Alex Koxaras Community Leader Dec 13, 2021

Hi @Sune Fonternel and welcome to the community!

What kind of values are you placing on the EDIT action? Can you provide a screenshot please?

If the values you enter above are correct, then you can try inserting a re-fetch component after the trigger and then let your rule run. See if that works!

Hi @Alex Koxaras

 

Thanks so much for the help and quick response!

 

Here's the screenshot of the Edit Action, it's all Copy from Current Issue:Capture4.JPG

 

I've tried the Re-fetch issue data in different spots, one at the end for both conditions, one as a "Then" clause after each condition, and one as an "And" clause under both and it's unfortunately still not working. 

 

I'm still seeing Success in the audit log with the right issue ID's 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events