Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Webex App not working properly

Hello,

I installed the Webex app on Jira cloud. I`m admin in Jira and in webex.
But everytime I want to start or schedule a webex from a Jira issue, I get the following message:
"You don't have a Webex Meetings host account on mycompany.my.webex.com. Contact your Webex Meetings administrator"

The Cisco support was not able to help me.
Does anyone of you know, what to do or has got similar experience with the webex app?

Thx

Rainer

1 answer

0 votes
Dario B Atlassian Team Nov 19, 2020

Hello @Rainer-Matthias Buchheim ,

I use neither the app nor Webex myself, but from the error message itself it looks like you have configured mycompany.my.webex.com as the Webex site that you want users to use for Webex Personal Room meetings in Jira.

Now, I am not sure whether this is correct or you have to replace mycompany with your actual company name. However, what I suggest to do is the following:

  1. Go to the app settings and make sure the Webex site URL and credentials have been correctly configured
  2. If this does not help, contact the app vendor using the details in: https://marketplace.atlassian.com/apps/1220501/cisco-webex-meetings-for-jira?hosting=cloud&tab=support

    Contact

 

Cheers,
Dario

Hello Dario,

thx for your reply.
mycompany is only a placeholder for my company. The settings in Jira are correct.
I have been in contact with the cisco support. They weren't able to help me and sent me back to atlassian ;)
Best,
Rainer

Dario B Atlassian Team Nov 20, 2020

Hello @Rainer-Matthias Buchheim ,

Can you please summarize a bit what has been found/done by Webex support? Did they determine that the issue is on Jira side or anything else?

Also, can you reproduce the issue with your browser developer tools open and check what is returning the error message? 

Cheers,
Dario

Hello @Dario B ,

unfortunately, the cisco support didn`t do anything.
The last message I`ve got, was the following:

It appears that the 2 apps are not communicating properly and uninstalling our plugin didn't work. The Jira support team should be able to tell us if something is wrong with the integration itself.

But before I contact the Jira support, I wanted to ask here, if someone has/had got the same experience.

I opened the Dev-tools in the Browser and got some warnings:
batch.js?is-feature-enabled=true&jag=true&locale=en-US:12551 WARN: 'triggerPrivacyPolicySafeEvent' has been deprecated

Sometimes, when I click on an issue and then on the "Cisco Webex Meetings" Link, it takes some seconds, then the App Buttons were displayed for just a second and then the text mentioned above appears again.

Thx,
Rainer

Dario B Atlassian Team Nov 24, 2020

Hello @Rainer-Matthias Buchheim ,

If you look at the network tab instead of the console, can you identify which resource/endpoint is returning the error message? 

Also, can you let me know date, time and timezone of when you are reproducing the issue in order to check the network tab, so I can see if I find anything in the logs? 

If nothing else helps then, as you already thought, the way to proceed is to open a support request with us in order to determine if the error is returned from our side or if there is any other issue.

 

Cheers,
Dario  

Hi @Dario B ,

thx for the answer.

I again looked at the network tab. There are only 200's and a few 304's so no error there.

I tried it from 5:15 PM to 5:20 PM CET

Maybe you find something in the logs..would be good ;) 

Best,

Rainer

Dario B Atlassian Team Nov 26, 2020

Hello @Rainer-Matthias Buchheim ,

I can see some lines related to the webex plugin in the logs but no errors in here as well:

2020-11-25 17:16:08.429 INFO com.atlassian.plugin.connect.plugin.auth.user.ConnectAddonLoginFilter.privacy-safe Setting user context header for request from app Cisco-Webex-Meetings - app account ID: Optional[5cc0e21b2f51be0e56a1b530]

2020-11-25 17:16:08.454 INFO com.atlassian.jira.rest.api.analytics.AnalyticsInterceptor.privacy-safe {"eventName":"jira.public.rest.api.call","resourceName":"UnrestrictedUserEmailResource","resourceMethodName":"getUserEmail","httpMethodName":"GET","httpResponseCode":200,"path":"/api/{v:2|3|latest}/user/email","pathPrefix":"","fullPath":"/api/{v:2|3|latest}/user/email","connectAddon":true,"connectAddonKey":"Cisco-Webex-Meetings","userAgent":"","clientType":"CONNECT_SERVER_TO_SERVER","executionTimeMillis":7,"data":{},"exceptionClassname":null}

2020-11-25 17:16:08.500 INFO com.atlassian.jira.rest.v2.permission.PermissionsResource getMyPermissions

 

Therefore, since no network errors or other kind of errors are seen in both, Jira logs and the browser developer tools, what seems to be happening is that  the remote end (mycompany.my.webex.com) is not recognizing the account credentials sent by Jira and therefore returns the message:

"You don't have a Webex Meetings host account on mycompany.my.webex.com. Contact your Webex Meetings administrator"

 

Now, before going any further, can you kindly let me know the following:

  1. If the plugin was working fine before and it suddenly stopped working or if it is the first time you use it (if it worked fine before, when did it stop working?)
  2. If the issue is affecting all the users in the instance or if it works for some users
  3. If the issue is only happening with specific kind of projects (e.g. only with Next-Gen or only with Classic) or all of them
  4. Is there any way you or Webex support can check the data sent by Jira to mycompany.my.webex.com in order to determine what is wrong? 

 

Cheers,
Dario

Hello @Dario B ,

thx for your answer and the log entries.
I`ll also forward them to webex support. Maybe, they can compare them with their logs.

To your questions:

  1. It was the first time, we installed the app. Haven't used it before.
  2. The issue is affecting all users of our instance
  3. It happens in all projects on all issue types
  4. I'll contact webex support again. Let's see, what comes

Best,

Rainer

Thanks for your quick reply on this @Rainer-Matthias Buchheim .

Before going any further, just to double-check, can you confirm that the email address of the Jira user that is trying to start the Webex meeting has a corrispettive account on mycompany.my.webex.com and is enabled for using personal rooms?

This is because on the app documentation I can read:

People with host accounts on that Webex site can use the app to start, schedule, and join Webex Personal Room meetings from Jira. Their Webex accounts must also be enabled for using Personal Rooms. 

 

If this does not help then please continue with Webex Support. Unluckily I don't have full access to your instance so there was a limited amount of things I could do. However, knowing what data is received by the remote end will help determining why the error message was returned. 

Once done, in case Webex Support will identify an issue with Jira (not likely, but it can always be the case), you can proceed opening a support request with us using: https://support.atlassian.com/contact

 

Cheers,
Dario

Thanks @Dario B ,

yes, it's the same e-mail-address on both sides and I'm admin for webex, which includes Personal rooms.

Already posted the above things to webex support. Let's see, what they find.

Best,

Rainer

Like Dario B likes this

You are very welcome @Rainer-Matthias Buchheim 

Have a nice weekend!  

@Rainer-Matthias Buchheimdid you ever find a solution to this? I'm running into the same problem, and not really getting anywhere with Webex support either.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Apps & Integrations

🍻🍂Apptoberfest Update: Upcoming Virtual Events 🎉

Hello Community! I hope you've been enjoying the 🍂Apptoberfestivities🍂 (I know I have!) The event is heating up next week with a series of virtual events that we're calling the 🍻🍂Partner App ...

107 views 1 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you