Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Updated soy wizard template not displaying when blueprint addon is uninstalled and reinstalled

My updated soy wizard template is not displaying when my blueprint addon is uninstalled and reinstalled.

Here's what I did...

1. Created blueprint plugin that contains a soy template wizard.

2. Uploaded blueprint plugin to Confluence via Manage Add-Ons.

3. Made changes to the soy template.

4. Uninstalled the first version of the blueprint plugin from Confluence via Manage Add-Ons.

5. Ran atlas-clean to clean my blueprint project directory.

6. Ran atlas-package to repackage my blueprint plugin.

7. Uploaded revised blueprint plugin to Confluence via Manage Add-Ons.

8. Selected my blueprint from Create dialog.

The wizard displays, but it doesn't show the fields I added. It's as if the revised soy template isn't getting picked up and thus isn't displayed.

Note: I also tried deleting the jar file that is created when you run atlas-package. Then I ran atlas-package again. That didn't work either. :-(

I also tried disabling the blueprint in the global templates list and in the individual space blueprints lists. Neither of these options worked.

3 answers

1 accepted

0 votes
Answer accepted

Hi Stacia,

Have you checked your confluence logs when the plugin is getting installed? Are there any errors?

If the soy is used to render the wizard form in the create dialog - it might be a caching issue in the browser. Did you try hitting shift+refresh?

Agnes

After doing some additional research (combing through the Confluence docs), it looks like I need to add feature discovery to my plugin. Specifically, the documentation says that if you change an existing plugin module, you need to unregister the module and reregister the module. Can someone confirm this?

And if this is the case, can you provide a sample Java file that shows how to unregister and reregister my module? I suspect this is fairly easy if you are a Java programmer; unfortunately, I am not one. So I am completely stuck.

Thanks, in advance,

Stacia

Hi Agnes,

Thanks for your help. It turned out to be an issue with my browser cache. Argh!

Note to Atlassian - it would be extremely helpful if you included a tip in your blueprint tutorials to let folks know that if they are making changes to their blue print plug-ins (which is highly likely given the nature of learning) and the changes don't show up, try refreshing your browser cache.

Hm if you were running Confluence with atlas-debug you should have caching turned off for you. Just curious, what browser were you using?

Agnes,

I mostly use Firefox. But occassionally I'll log into my dev environment with Chrome or IE.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Happy New Year and Welcome New Marketplace Partner Program Partners!

Happy New Year! We hope you all had a safe and restful holiday season. 2020 was a unique year full of unforeseen events; however, as we enter the new year of 2021, we’re optimistic for the light at t...

820 views 7 24
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you