Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,676
Community Members
 
Community Events
176
Community Groups

Unable to View User's Timesheet in Tempo Timesheets

When I am in Tempo Timesheets, click on 'User' and try to find anyone else's timesheet besides myself, I am not able to find anyone. No other names apprear. I am a jira-administrator, so I thought I should have this permission. What permission am I missing to so I can see everyone else's timesheet? I would also like to give this view (permission) to other to look at as well.

Any ideas?

Thanks,
Chris

3 answers

1 accepted

2 votes
Answer accepted

Hi Chris,

You need 2 things:

- Browse Users Global JIRA permission

- To view UserX you need the "Approve Timesheet Permission" for a team which UserX is a member of.

Hope this helps!

Benedikt

Benedikt,

Right on! I did NOT have my global JIRA permission set to browse users. After I set the permission, I was able to view everything perfectly, thanks.

Chris

After some additional testing, I ran into another issue. By adding users to the Browse Users Global JIRA Permission, they now have access to view all project. Previously, I had it setup so users were only able to browse project that they were involved in and NOT all projects.

Is there any way to give users access to this information without giving them access to all projects? Is there a browse users permission at the proejct level?

Thanks,
Chris

Hi Chris,

One solution would be to use the Browse Project permission in JIRA: https://confluence.atlassian.com/display/JIRA/Managing+Project+Permissions

Benefikt,

Ahh yes, I beleive it is now working properly for me after this change. Thanks for all your help!

Thanks,

Chris

Until yesterday I used to be able as an Administrator to search for a user or view a users time logs on Tempo timesheet view. My global JIRA permission is set to browse Team and Approve Timesheets. What happened since yesterday? I am unable to select any team member/user.

Thanks

AJ

Like the post above, I just noticed that I no longer can enter time for other users. This is new behavior- I have been able to enter time for other users in the past.

Hi Benedikt,

I am unable to see tempo timesheet for other users ?! Cna you pls suggest where i can see the report of all the employees ?!

Hello,

From the last few days, entire team is logging their spent hours in Log work section and I was able to see their timesheet in Tempo as well. But around 3-4 members are logging their hours but I cant see their timesheet in the list. I thought its Jira Backend issues as its taking time to get update but now its more than 1 week, its still not working. Would you please let me know how it could be resolved?

 

 

Regards

Nidhi

Hi @Nidhi Sachin Jindal ,

In case you are on the Cloud version, can you please navigate to Jira Settings > System > Global Permissions and make sure that the “atlassian-addons-admin” group has the "Browse users and groups" Permission. IN case this group does not have the permission, please add it.
Add-ons require this permission to check on user permissions in your system.

In case the atlassian-addons-admin group has the Browse users and groups permission, can you please create a ticket in our Tempo Support (https://tempo-io.atlassian.net/servicedesk/customer/portal/6)
so we can better follow up on this.

Regards
Susanne Götz
Tempo team

Hey Susanne, I still with all these permissions can't log time for other people, what do you I do? 

Hi @Artyom Surjikov

have you tried to type the beginning of the name? The dropdown is not getting populated unless you start typing.

BR

yes, and it's not working too 

Hi @Artyom Surzhikov

Can you please create a ticket for this in our Tempo support system, https://tempo-io.atlassian.net/servicedesk/customer/portal/6 so we can better investigate this problem.

Best regards,
Susanne

I don't seem to have access their and it's not allowing to login with SSO 

Thank you for the answers. We followed the suggestions here, but our power users were still unable to view the timesheets of other users. We eventually discovered the need for a link between teams and projects.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events