Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,979
Community Members
 
Community Events
168
Community Groups

Trouble authenticating API request in Table from JSON macro

I've had success with most features and macros in the Table Filter and Charts product, including simple API requests where the auth token is in the URL. However, For requests that require a basic auth header, I always get a 401 unauthorized error in the response. I can test my request in Postman without issue. I'm trying to use the "custom" header and using variations of basic mytoken or authorization: basic mytoken... But so far I haven't found the trick to getting this to work. I've whitelisted the source urls too. I'm not sure what I could be missing or if this is a bug.

2 answers

1 accepted

0 votes
Answer accepted

For me the solution was using my token which typically would reside in the username field of a basic auth header with a colon at the end was to use the token with a colon at the end, convert it to base64 and use that in the custom header option of the macro.

Hello @mwilder,

Did you try to enter login and password into the Table from JSON macro?

If this doesn't work, please tell me more about the request and authentication you use in the Postman. Or you can contact Stiltsoft support.

Hello @Andrey Khaneev _StiltSoft_ ,

Yes, I've also tried the username and password option, filling in only the field for username with the token. I've tried every format I can think of including ending the token with a colon, or not, using both kinds of authentication headers available.

 

The API I am attempting to request data from is documented here:

https://developers.cloudability.com/docs

And the request I am submitting is a simple one, retrieving a short list of vendors:

https://api.cloudability.com/v3/vendors

 

The application provides a basic auth token to be used. When I set it up in Postman I select basic auth and enter the token into the username field.

 

What Postman generates for the request is as follows:

curl --location --request GET 'https://api.cloudability.com/v3/vendors' \--header 'Authorization: Basic MyToken' 

Did you try to set a custom auth header and enter Basic MyToken in the input?

Yes I have, I expect that would be the method which would succeed but I still encounter an error. Are there configurations or settings in Confluence that are required to enable this which could be interfering? 

Please, create a support ticket where we'll continue the investigation of the issue. I think a call with screen sharing will be more productive in this case.

Ticket created     TFCS-374

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events