Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Tempo Timesheets: Unable to import accounts.csv (Bug?)

Because we are migrating from server to cloud, we would like to export/import accounts.

But importing into cloud does not work:

1. Screen: Selecting file. Works.

2. Screen: Mapping attributes. Works.

3. Screen: Validation. In the last tablecolumn "Validation" I get a message on every row:

"No account key suppliedInvalid Account Name - No name suppliedNo lead supplied"

But I think the csv must be valid. Even if I import the downloaded template.csv provided by tempo plugin I get these errors.

3 answers

I have found an answer to this, Before you import the Accounts CSV into Tempo Cloud, you need to manually match the current user key from Jira Server to the new Atlassian Account ID.

The atlassian account ID is a numerical string found by browsing Users in Jira cloud, clicking the username to administer, the copy the last string of text from the URL. Replace the Jira Server user key with this new Atlassian cloud ID.

1) Export Accounts CSV

2) Ensure the CSV headers are 

Account Key;Account Name;Customer Key;Customer Name;Contact;Category Key;Category Name;Account Lead Username;Account Lead Name;JIRA Project Keys;Global Account;Monthly Budget;Status

3) In the export from Server, you will likely see 2 fields for Users. "User.IdName";"User ID" for example.

Replace the "User.IDname" (this will be Joe.Bloggs for example). with the unique Atlassian ID from the users management URL.

E.G.   << This.

4) Repeat for all users.

Download template



Downloaded template looks like this:


Import downloaded template:

step3.PNGMap attributes (even its a template provided by tempo)


Then validation fails


I guess the problem with the lead is that this user does not exist in Cloud.

I checked my account keys and names and the account key consisted of letters and account name did not have the ":" sign. Maybe it is the reason. Though I am not sure.

I tried it with all sorts of valid csv-formating like double-quotes and with our accounts export from jira server (we also use letters as as keys) and I created the lead user in the cloud... 

I also created just one single demo account in the cloud, with exinsting user als lead... then i exported that account, but it was not possible to re-import that csv.

I will double check the documentation, maybe I missed something.

Thx for your help anyway, must be something with our data if its working for you!

Hi @maystormgames 

Did you manage to get this working. We are experiencing exactly the same issue. 

Steps from Server -> Cloud

  1. Export all accounts to CSV file
  2. Edit this file so Account Lead ID and Account Lead Name are in this file correct
  3. Go to tempo in cloud -> import/export
  4. Select the file and map the values
  5. Error that the account key and account name are not correct 

Steps from Cloud -> Cloud

  1. Create a fake account on tempo cloud
  2. Export this account
  3. Import this account
  4. Same error

Screenshot 2021-04-17 at 09.31.09.png

Hope to hear from you soon. 

Hi @maystormgames ,

I found the issue from our side. We allready configured Jira and Tempo in our own language (which is Dutch, as you can see in the error message). 

After inspecting the response from the api request we saw that we did send the correct information but the error message told us he was looking for the Dutch values. 

After switching Jira, my account and everything I could find back to English AND clearing the cache and logging out and back in again, it worked.

0 votes


Unfortunately I can not see your screenshots. Did you map correctly the account key? I imported accounts from Server to Cloud this Saturday and worked fine for me.

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events