Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,703
Community Members
 
Community Events
176
Community Groups

Tempo Date Format

Am I the only person in the USA who has noticed that the date format on tempo time sheets is wrong?  Perhaps my employer is the only one in the USA to use this UK-based tool.

My profile is set up for ENGLISH UNITED STATES.  

So the dates should show as MM/DD.

However, on the tempo timesheet, the dates are displaying as DD.MM instead of MM/DD. For example, today is May 9. The date should show as 05/09. Instead, it shows as 09.05, which makes me think it is September 5.

This is very confusing, as this is not the USA format for dates.

We have had TWO releases of this product, and STILL, the bug is not fixed.

I welcome people from the UK to try looking at dates as MM/DD for TWO YEARS EVERY SINGLE DAY and see how THEY like it.

Please, please PLEASE, FIX THE DATE FORMAT.

4 answers

The answer is to FIX THE BUG.  Not in four years, but NOW.

This has been driving me crazy for YEARS! I keep looking for some setting to fix it, but none exists. This is ridiculous that this is just a bug that's existed for this long, especially since bugs for this were filed nearly 6 years ago, with a fix promised 5 years ago!

Please, please, please fix this!

I'm a developer, so I'm guessing this is just one of those bugs that's really easy to fix, but seen as a low priority because of how it doesn't crash the app or destroy data or anything. But it's insanely annoying. As the OP suggests, have the people in UK try to switch to US format and they'll see very quickly how critical this "non-critical" bugfix is.

Thank you for your support, bgunn.  

Like Richard Scire likes this

I am getting complaints from my users as well.  

Thank you for your support, Debbie Jones.

We just migrated to the cloud last weekend and I noticed it and I'm getting user complaints also.

Like # people like this

So, having cursed this plugin for 5 years, I finally took the time to figure out what it was doing and how to do something about it.

1. Make a directory to host our fixed script:

mkdir /var/www/jira-fixups

2. Retrieve your current version of the script, it'll be something like this (use your favorite web browser to find the equivalent url or check your web server's logs):


curl 'http://127.0.0.1:8090/s/d41d8cd98f00b204e9800998ecf8427e-CDN/-k6js55/73011/b6b48b2829824b869586ac216d119363/8.7.0/_/download/batch/is.origo.jira.tempo-plugin:tempo-smartsheet/is.origo.jira.tempo-plugin:tempo-smartsheet.js' > /var/www/jira-fixups/tempo-smartsheet.js

3. Replace the annoying code with something less annoying:


perl -pi -e 's{"MM.DD":"DD.MM"}{"MMM DD":"MMM DD"}' /var/www/jira-fixups/tempo-smartsheet.js

Note: by fixing it this way, I don't have to care about whether some of my users actually like DD.MM behavior, none of my users will have *any* problem parsing MMM DD.

This assumes you're using Apache 2.4 and it's using mod_proxy of some sort to connect to your Jira install:

4. Tell Apache not to send queries for this file to Jira, instead.

Insert this:


ProxyPassMatch "tempo-smartsheet.js" !
ScriptAliasMatch "^.*tempo-smartsheet.js$" "/var/www/jira-fixups/tempo-smartsheet.js"

Before:


ProxyPass / http://127.0.0.1:8090/ retry=0

Or whatever your equivalent thing is.

It should be fairly easy for people to adapt this last little bit to suit their proxy environment.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events