Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,441
Community Members
 
Community Events
176
Community Groups

Sprint permissions: what to do with a greyed out “Create sprint” button

Sprint-permission-Article-image-EN-1-800x400.jpg

Jira by Atlassian is the perfect software to support you to configure your Scrum process effectively. Thereby, it is important that the Scrum Master has the ability to create sprints for all needed projects to structure the process effectively. This happens in Jira through the button “Create sprint”.

Unfortunately, it can happen that this button is greyed out and the note “You need the permission manage sprints for all projects” appears. Because of this problem, the Scrum Master can not create sprints. Since this issue caused difficulties for many companies, we will provide you a smart and easy solution through this article.

The problem

The Scrum Master wants to create a sprint. Though, the button for the sprint creation is greyed out and the note “You need the permission manage sprints for all projects” appears. Because of that, the Scrum Master can not create the needed sprint.

The solution

Step 1: Examination of the permissions of the Scrum Master

To solve this problem, it is important to check if you have the permissions “Manage sprints” and “Plan Sprint”. To check this, you have to go to permission scheme.

Check here if checkmarks are set for the permissions “Manage sprints” and “Plan sprints“.

If not: Add the checkmarks and check if the “Manage sprints” button works now.

If not: Continue with step 2.

If the checkmarks are set, but the problem still exists: Go on with step 2.

Step 2 : Creation of the right filter

If you can’t use the button but have the permission to create sprints in reality, follow the next instructions:

The underlying problem is often caused by an incorrect filter on the JQL board, which is created automatically. Often times, this filter includes not all of the permissions that are needed to enable the Scrum Master to create sprints.

The filter should either add all permissions that should be included through the function “in” or should take all permissions out that should be excluded through the function “not in”.

Therefore, it is important to pay attention to the allocation of permissions to create the filter effectively:

If more permissions should be included than excluded: Use the function “in” and fill in all permissions that should be included.

If more permissions should be excluded than included: Use the function “not in” and fill in all permissions that should be excluded.

Use the function "in":

Use the permission "not in":

It is important here to ensure, that all needed permissions are included in the filter. Already one missing permission can prevent the Scrum Master from creating sprints.

Create the filter in the described way and use it. Afterwards, the problem should be solved, and the button should be usable.

If the problem still exists, you can always reach out to us through our contact form. We as Actonic are always ready to help you with advice and action!

An example

“John Smith” is a Scrum Master at the “example corporation”.

The example corporation has the following project list:

  • Software
  • Hardware
  • Project management
  • HR
  • Accounting
  • EDP
  • Trainee
  • Sales

Mister Smith wants to create sprints for software, hardware, trainee and project management. Unfortunately, he cannot create these sprints because of the gray “create sprints” button. He follows the following steps:

Step 1:

Mister Smith checks if he has the permission to create sprints at the permission scheme and if the checkmarks for “Manage sprints” and “Plan sprints” are set. He finds out that both permissions are ticked.

Step 2:

Mister Smith checks the filter.

The filter looks like this:

project not in (“HR”, “Accounting”, “EDP”) ORDER BY Rank ASC

The problem:

He has to exclude "Sales" from the filter. The underling filter assumes that Mister Smith wants to create sprints for "EDP" too, for what Mister Smith has NO permission.

Mister Smith adjusts the filter in the following way:

project not in (“HR”, “Accounting”, “EDP”, “Sales”) ORDER BY Rank ASC

Through this filter 100% of the projects are excluded, for which Mister Smith has NO permission.

Solution: Mister Smith can create sprints for all needed projects because of the flawless filter.

Would you like to learn more? Simply contact our experts for a Jira training.

2 comments

Hello,

Is there a reason why the project switches from English to German?

project not in (“HR”, “Accounting”, “EDP”) ORDER BY Rank ASC

then:

project not in (“HR”, “Buchhaltung”, “EDV”) ORDER BY Rank ASC

Also why isn't this filter Added too, i.e. if were adding EDV as the exclusion why not:

project not in (“HR”, “Accounting”, “EDP”, "EDV") ORDER BY Rank ASC

It's a little bit of a confusing example using two similar named projects, one who doesn't appear on the first project list.

Hi @GLiNTECH Managed Services

thank you for the feedback, we've fixed the projects naming. I hope now it looks fine :)

Comment

Log in or Sign up to comment
TAGS

Atlassian Community Events