It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SLA info isn't updating until I run "SLA Generation for existing issues"

Jason Smith Feb 09, 2016

I've set up pause and reset triggers in the config to test the SLA functionality. No matter what I do, the "TTS - Time To SLA (New)" field doesn't update in the issue or the issue navigator until I run the manual refresh on the /plugins/servlet/tts/configure/generate-sla-history page. 

Why is this step necessary? Shouldn't the SLA be updating in the issue? I tried reinstalling the plugin to no avail., as well as re-creating the SLAs. 'm running JIRA 6.4.1 and the latest version of the TTS plugin (5.10).

This is a glance at the config. The pause condition is the Done status and the Reset condition is changing of Resolution. It seems like the SLA doesn't reset no matter what (the SLA is not met forever, even if I go through a reset condition).

I've also tried reindexing JIRA and that didn't seem to make a difference.

slaconfig1.JPG

How should I go about fixing this?

3 answers

1 accepted

1 vote
Answer accepted
Tuncay Senturk Community Leader Feb 10, 2016

Further investigation gives us the result that "Store data in database" option was unchecked.

It should be checked. Admin > Add ons > Time to SLA > Custom Fields 

image2016-2-10 22:22:21.png

0 votes
Tuncay Senturk Community Leader Feb 09, 2016

Hi Jason,

Generate SLA link is designed to be run for generating SLA data for existing issues (before the plugin installation).

So, you do not need to run it for the issues after plugin installation.

Could you please give us more details? For instance what happens after creating issue? I mean does TTS field display anything? What about any other status change (from To Do to In Progress)?

Actually I do not think this problem is just a question and needs further investigation, so we can continue this topic in our bug tracking tool if you raise an issue and give us more details. 

Tuncay

0 votes
Jason Smith Feb 10, 2016

Per Tuncay in https://bitbucket.org/tuncaysenturk/time-to-sla-plugin-for-jira/issues/161/sla-info-isnt-updating-until-i-run-sla, checking the "Store data in database" box on /plugins/servlet/tts/configure/customfields fixed the issue.

Tuncay Senturk Community Leader Feb 10, 2016

Could you please accept my latter comment so that other users can see the solution immediately?

Thanks

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted in Marketplace Apps & Integrations

Demo Den Ep. 4: Continuous Integration with CircleCI & Jira Software

Get ready! Demo Den Episode 4 is coming your way on Tuesday, May 28, 2018 with a Continuous Integration and Delivery special demo. CircleCI Director of Solutions Engineering, Eddie Webb will show us ...

409 views 0 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you