Pasting into HTML macro partially decodes HTML

Rolf November 6, 2019

I've noticed that pasting into an HTML macro (old editor) has recently broken.

 

If you do something as simple as type this:

>

And then copy and paste it, it will be pasted as ">" instead of "&gt;".  This breaks my ability to use HTML macros.  I paste in relatively large blocks of HTML that include hundreds of &gt; and &lt; which now get replaced by <> which ends up being invalid HTML.

2 answers

0 votes
David Šerý August 30, 2021

Hello, was the ticket already created / issue solved? The only thing I found was this page, which neither has a reply not a ticket attached. (https://community.developer.atlassian.com/t/paste-html-character-entity-references-like-lt-is-immediately-decoded-by-macro-body-editors/36796)

I am facing the same issue currently and would love to have a good solution.

Rolf August 30, 2021

I raised a bug on another page.  The bug was acknowledged years ago, but no progress has been made on a fix.  I get the impression that they have no interest in fixing this.

In the end, I created a script to escape all my HTML before copying it into the clipboard.  That way, when I pasted, it looked correct.

0 votes
Brendan Patterson
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
November 25, 2019

Hi @Rolf ,   Is this for the Confluence Cloud HTML app found here?

https://marketplace.atlassian.com/apps/1212279/html-macro-for-confluence-cloud?hosting=cloud&tab=overview

 

If so then please open a ticket here if you haven't already:

https://artemis.atlassian.net/servicedesk/customer/portal/3/group/-1

 

Thanks!

Brendan

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events