Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,190
Community Members
 
Community Events
176
Community Groups

POST method, REST API : fix version required

I am facing a problem with the robot framework multipart option of the REST API, I tried to create a new test execution and import the result of the output.xml thanks to curl but REST do not accept my json file below :

{
"fields":{
"summary":"Test execution from Robot Framework",
"issuetype":{
"id":"10004"
},
"project":{
"id":"10301"
},
"fixVersions":[
{
"set":{
"id":"10300"
}
}
]
}
}

 

Rest give me this output :

fixVersions: Fixed version (s) is required.


Thanks for your time !

1 answer

1 accepted

0 votes
Answer accepted

I'm not sure why you have put in the "set" part of the value.  fixVersions expects an array of version objects, which doesn't need any control on top of the array indicators.

Try:

 "fixVersions":[{"id":"10300"}, {"id":"10301"}]

(Obviously, remove the 10301 element, I've added it to show that it's an array)

Also, you can get this error if the version selected is not for the project you are in, so it may be worth checking that too.

Thanks a lot for your reply, I tried your solution before but wasn't working, I resolve the problem this morning, it was my robotframework xml.
Dont know why but Jira do not accept it and ask me the fixVersions.
I tried with the robot framework example xml and all is working !

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events