Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,811
Community Members
 
Community Events
176
Community Groups

Missing Development Panel? GitHub Integration

I've done quite a bit of searching with no luck. And it seems I'm not the only one struggling with this. 

I followed the GitHub instructions to the letter. Both sides (GitHub and Jira) show that everything is green lights all day. But when we commit messages to repos with the smart syntax, we get nothing. Even the dev panel is missing. 

This seems like an issue on the Atlassian side of things since the panel is missing entirely. But the support docs all point to GitHub for issue resolution. So I'm posting here, hoping the Atlassian team (or a fellow user) has any ideas of what to try. I'm at a loss of where to even start right now.

10 answers

Yes, I'd like to echo the fact this has been absolutely painful to setup (Still waiting to see if a "full" refresh works). If Atlassian does not make the integration more seamless with GH I suspect accounts will continue closed. Very disappointing. 

Same issue, can't see development panel with GitHub Enterprise, the panel only appear when connect to Bitbucket.

Hi, if you don't see the Development Panel on the issues and the integration is set correctly, it may be because you don't have the permission to see it : 

By default, users that are allowed to see the development Panel are those with a Project role of : developers, atlassian-addons-project-access

If you have a different Project Role, you can fix this by targetting yourself in the permission, via Cog Icon > Issues > Permission Schemes > {the permission scheme where the projects are involved} > View Development Tools.

Hope it helps ! :)

Sources :
https://support.atlassian.com/jira-software-cloud/docs/view-development-information-for-an-issue/#Viewingthedevelopmentinformationforanissue-Beforeyoubegin
https://confluence.atlassian.com/jirakb/how-to-remove-or-edit-access-to-development-panel-701268686.html

Quick update for those watching this.

I've tried every solution in this thread plus some. Nothing changes the status and even after a 30-day wait with no edits, it does nothing. The more time we spent with the Jira system the more we like it but with our actual work being almost entirely in GitHub, it's crucial to our speed and communication that we can see commits, issues, and PRs alongside our stories.

So, with this integration continuing to fail, we gave up on Jira. We built out our own system on top of Discourse and cancelled our account with Atlassian. It's cheaper and more importantly, it works!

Thanks to everyone who offered help here. Unfortunately, nothing works here and I have to make the recommendation that anyone doing development work in GitHub should avoid Jira.

for us, the development panel was not displaying even though the GitHub Configuration status was "COMPLETED".  i clicked on the GitHub Configuration -> Retry button.  status went to PENDING and after ~5 min went to COMPLETED. after that we were able to see the Development panel on our tickets.

This worked for me as well. Thanks, Ronda.

There are two Retry options, "Normal" and "Full". Normal did not change my ability to see the development panel, but Full did.

So I did two things based on this thread:

  1. Went from selecting "All Repositories" to selecting the repositories individually that I wanted to sync (about 20)
  2. Went through a "Retry" -> "Full" -> Submit

The status changed from "Completed" to "Active" to "Completed", and my recent pull requests on my test issue were visible without me having to resubmit the pull request.

Suspecting that step 2 may have been the only thing I needed to do, I went back to "All Repositories" again. Status went from "Completed" to "Active" to "Completed" and the development panel was still visible on my test issue.

Thanks again!

I had this problem too. Whatever I tried, I could never see the development panel or get the two services playing nicely.
Here's how I fixed it:
- It seems that the synchronization is very slow for a large number of GH repositories so the first step is to reduce that down to a handful if at all possible.
- Next up I couldn't get the sync status to change from "Active" to "Completed" until I re-added my organization (without removing it to begin with). Once the organization was added a second time, the sync status took a minute to change from "Pending" to "Completed"
As mentioned above, once the "Completed" status was achieved, the integration just worked, I made another commit on the GH and it appeared in the developer panel on Jira.

I'm adding this in the hope it helps someone else.

PS: It's also worth noting that the integration is actually open sourced and you can check it's activity out (or lodge any issues) here: https://github.com/integrations/jira

Good luck

Thanks that hint with the status helped.

0 votes
BillyP Community Leader Nov 15, 2018

So the answer was to wait it out?  

Well, what I did first was to re-configure it with just a single repo (rather than All) to prove that it worked. Even that took a few minutes. 

 

But yeah, that was the answer for me.

Hey folks,

 

Quick update on my end. My Github account included a lot of repositories and I selected "All Repositories" in the "Repository Access" section when configuring the addon.

 

The sync status said "Active" which is misleading because I thought that meant it was done. Apparently there is also a "Completed" status which means that all the repos are now available.

 

So I believe it may just take some time before all repos can become available (multiple hours in my case).

Good to know, @Michael Witwicki. We have almost 80 repositories on our end. Can I ask how many you're working with?

We're still sitting in Active status. So maybe we need to wait for Completed.

I installed it 4 days ago. Though right now it says it was added 24 hours ago. Which is weird. Maybe it's just a matter of time. Not sure why it would take so long for an API connection like that, though.

Like Michael Witwicki likes this

We have 86 repos. It took somewhere between 2-6 hours (I was away for a while so I'm not sure). I bet they need to space the API requests to avoid hitting limits or something. But either way, it definitely completed, just took a while.

Like Joe Buhlig likes this
0 votes
BillyP Community Leader Nov 15, 2018

Hi @Joe Buhlig 

What are the security settings on the repos?  

Can you create a test project in Jira and test repo in Github to remove some of the possible variables?

:)

The repos are mostly private with a handful of public. Not sure what settings would matter since the app has account access. So it shouldn’t matter. 

Like sam_almen likes this

Our setup is exactly the same @Joe Buhlig - primarily private with a few public.

I'm in the same boat here. I'm wondering if the Development Panel just isn't available for Next-Gen projects or something?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events