Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Keep Getting Error "Could not upload the file to Confluence. The server may be unavailable"

Every single time I click "Insert Link" and then try to Upload a File it gives me the error: "Could not upload the file to Confluence. The server may be unavailable." If I then click cancel and then go back to Insert Link > Files, the file I tried to upload is uploaded. Why must I need to go through this process of clicking cancel and then clicking back into Insert Link for it to work properly? Any help is greatly appreciated.


Thank you!



2 answers

0 votes
AnnWorley Atlassian Team Nov 22, 2017

Sometimes the issue you are reporting occurs when the base URL does not match the URL you are using. This page has two other possible causes as well as resolutions: Upload attachment function does not work in editing mode

I look forward to hearing whether any of the resolutions work for your case.

Hi Ann,

I have confirmed that the configured base URL matches the URL used to access Confluence via browser so that should not cause the issue. 


We do have Brikit Theme Press. How can I check what version of Confluence I have? I don't believe we would have a legacy version because we just signed on in September. If Brikit is in fact causing issue is there anything else we can do to solve for this? Or will this just keep happening?


Thank you,


AnnWorley Atlassian Team Dec 12, 2017

If Brikit is causing the issue we can move your question to the part of the Community where the Brikit support team can address it. Maybe they will recommend a newer version of Brikit.

To check your version of Confluence, please go to Confluence Admin>System Information. Alternately, on many instances there will be a "powered by Atlassian Confluence" footer with the version:Screen Shot 2017-12-12 at 2.27.44 PM.png 

Looks like we have Confluence 6.4. According to the page you sent me to, the Brikit issue was only reported with legacy versions (e.g. Confluence 5.6.X). Therefore still not sure what it could be. 


If you still think it is a Brikit issue, can you please move my question appropriately?


Thank you,


AnnWorley Atlassian Team Dec 12, 2017

Thanks for checking the version.

I just tested Brikit Theme Press 2.1.1 with Confluence 6.4 and I was able to upload attachments in the editor without the error message. So I think we need to collect more information.


  • Try a different browser and/or clear your browser cache to make sure it isn't a browser issue.
  • Upload an attachment to generate the error and then check the latest log entries (at the bottom of the files) for your username or anything that starts with ERROR and mentions the attachment.
  • The logs are located in: 
    <confluence_install>/logs/ (anything recent in this directory)
    <confluence_home>/logs/atlassian-confluence.log Note: The <confluence_home> directory is the path defined in the following file: <confluence_install>/confluence/WEB-INF/classes/
  • If you have a maintenance window coming up please try plugin safe mode to eliminate user installed plugins as a cause.
  • If the attachments upload properly in plugin safe mode, please try clearing the plugin cache.

I look forward to hearing what you find.

I tried a different browser and cleared browser cache and still got the error.

How do I see the logs? What do I replace <confluence_install> with? I tried to replace it with the base URL but that didn't work.

AnnWorley Atlassian Team Dec 12, 2017

The logs are on the file system. The install directory is where all the Confluence program files are, it's specified when Confluence is installed and varies between instances so I am not sure what yours is.

On the Confluence Admin>System Information page the Application Server Working Directory is <your_confluence_install>/bin, in case you need to find it.

If you don't have easy access to the file system a useful tool is the Support Zip. You generate that under Confluence Admin>Support Tools> Support Zip tab. After you generate it you can download it from a link that will be displayed. (Then unzip it.) The install logs will be in the folder tomcat-logs and the atlassian-confluence.log will be in the application-logs directory.

I'm not seeing any of this so I don't think I have the right permissions. I'll ask our administrator to pull the logs and will get back to you.


Thank you!

Hi Ann,


Not sure exactly what to look for. I can send over the zip file if that will be easier, but here are snippets of what I see:


ERROR [http-nio-8090-exec-6] [brikit.core.log.BrikitLog] logError Failed to read JavaScript file in Brikit Theme Press: theme-press/scripts/frames.js
-- url: /display/AC/Accounting+Home | traceId: 7e51035481edc779 | userName: merchandmark | referer:
2017-12-12 21:17:50,396 ERROR [http-nio-8090-exec-7] [brikit.core.log.BrikitLog] logError Failed to read JavaScript file in Brikit Theme Press: theme-press/scripts/frames.js
-- url: /brikit/pages/editpage.action | page: 1181003 | traceId: 97244d066acf0814 | userName: merchandmark | referer: | action: editpage
2017-12-12 21:28:13,779 ERROR [http-nio-8090-exec-8] [brikit.core.log.BrikitLog] logError Failed to read JavaScript file in Brikit Theme Press: theme-press/scripts/frames.js
-- url: /display/AC/Accounting+Home | traceId: a9275868e3d6ea62 | userName: merchandmark | referer:
2017-12-12 21:28:20,575 ERROR [http-nio-8090-exec-8] [brikit.core.log.BrikitLog] logError Failed to read JavaScript file in Brikit Theme Press: theme-press/scripts/frames.js
-- url: /brikit/pages/editpage.action



referer: | url: /plugins/brikit/pages/apply.action | traceId: 9435d222d63249f8 | userName: merchandmark
2017-11-22 19:42:37,436 ERROR [http-nio-8090-exec-7] [[Standalone].[localhost].[/].[servlet-module-container-servlet]] log Servlet.service() for servlet [servlet-module-container-servlet] in context with path [] threw exception Not a valid requested file in
at com.brikit.themepress.servlet.BrikitServlet.validateRequest(
at com.brikit.themepress.servlet.BrikitServlet.doGet(
at javax.servlet.http.HttpServlet.service

AnnWorley Atlassian Team Dec 13, 2017

Those errors do point to an issue with Brikit. I am going to move your question to get attention from the vendor. I will still see any updates so your case will stay on my radar.

AnnWorley Atlassian Team Dec 13, 2017

@Digital Media 

I found Brikit's support portal as well, it could be another resource:

Hi @AnnWorley and @Digital Media,


The errors mentioned above are known bugs in Theme Press which are currently being tracked on the following tickets:


The "frames.js" issue should not affect the upload. The error is logged because an non-existing file is referenced in our product when merging the JavaScript files.

The second issue, which we are still investigating,  happens when a theme file (eg. image) cannot be found in the server. This is theme specific and it is triggered during GET requests and not POST.

@Digital Media could you attach a Support Zip in our open CC ticket for us to investigate further?

@Ricardo Martins I attached the zip file to the CC ticket. Thanks!

Not an answer but a pile on. I'm on Confluence Data Center v7.3.5 and we don't even see the error. There's just a really quick flicker and the dialog is unchanged. If I click Cancel and then immediately try again, the file I was trying to upload from a local folder is there and then I can add it as a link. A user brought it to my attention - Until recently we were on Confluence Server v6.1.2 and I always used the Attachments method of getting files to a page and then I'd go in Edit mode and surface the attached document in whatever way made sense at the time. I don't think Link > Files was even an option in 6.1.2.

Anyway, we don't have Brikit installed so that's not what's going on for us. We have very few apps inf act.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Marketplace Apps & Integrations

New Cloud Apps Roundup - April 2021

Atlassian's marketplace partners have had a very productive start to 2021! Since our last roundup, our developer community has added over 160 new cloud apps to the Atlassian Marketplace to help you...

290 views 3 20
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you