Jira no longer shows Test cases. says You are not yet logged in to TestRail.

Larry Sutton June 10, 2020

My Jira does not show me the TestRail Cases or Runs. Yet in TestRail, it will display the Jira detail and allow me to open the JIra.

JIra shows: "You are not yet logged in to TestRail. Please log in to use the integration."  and a Log in to TestRail button. The button opens ReatRail into the Dashboard. No login required as it is already open.

This used to work. I depended on it. It stopped working.

How do i fix this?  I redid the Jira token but that is only for the testRail side.

13 answers

1 accepted

2 votes
Answer accepted
Nikita August 7, 2020

Hello Larry!

I've got the same issue and I think I found the answer. Here is the full question on Gurock and problem description. A brief steps, that helped me:

  1. Paste this in Chrome: chrome://flags/#same-site-by-default-cookies
  2. Set SameSite by default cookies to: Disabled
  3. Restart Chrome
Larry Sutton October 28, 2020

Well, I cannot confirm this fix works. My setting was already Disabled and when i re-tried the issue, it works.  It did not work a couple of days ago.

But it would not be the first Chrome setting to affect TestRail.  

It may have been the TestRail update mentioned in the "full question". Edge works too.

Guhan January 5, 2021

Did anyone notice the behavior in Safari? I am having similar issue as Larry, but I am using Safari in Mac.

hanna_podoliak January 12, 2021

You need to remove website tracking

Screenshot 2021-01-12 at 16.18.31.png

Like # people like this
Guhan January 12, 2021

Thanks Hanna. It is an issue with Safari and I could see the test cases in Chrome after turning the flag off. It is still an issue with Safari and I do not think Atlassian has an answer for that. Thanks for the response again.

Olga Zaslavska
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 28, 2021

Thanks Hanna! ♥

It helped! 

vaughn segers
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 4, 2022

Thanks Hanna! Worked for me.

Process on Firefox:

  •  goto Settings >> Privacy and Security
  • Click Custom
  • de-select Cookies
  • a button will appear to "Reload All Tabs". Click it
  • note: I needed to reload my tab manually
Like # people like this
Hayden Molijon
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 10, 2022

This is frustrating as the solutions above will have to be applied to each individual users of JIRA.

3 votes
Sergei Nechai October 4, 2021

Hi!

This is a possible solution that worked in my case today to fix the "Log in" in Jira:Possible_Solution.png

In Chrome Developer tools > Application > Cookies > testrail set for tr_session:
Secure : True (checkmark)
SameSite : None
Integration then worked for me.

Probably this could be managed in Firefox also somehow.

Cheers!

mcguier-air
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 5, 2021

Works for me (Chrome 94.0)! Thanks, Sergei!

2 votes
Roaa Rasheed October 4, 2021

I'm facing this issue today , using Chrome, FireFox latest updates and TestRail v7.1.2.1084.

Can any one help ?

Sergei Nechai October 5, 2021

Hello!

Try to edit TestRail cookies, this helped me
Possible_Solution.png

Like Roaa Rasheed likes this
2 votes
JoseRoberto.Vargas
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
September 10, 2021

Anybody has a fix for this in the current Chrome Version?

2 votes
dan
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 25, 2021

Our teams are seeing this issue as well on chrome. it does work on firefox...
we have tried ' chrome://flags/#same-site-by-default-cookies  SameSite =Disabled' but to no effect.

issue: in chrome (92.0.4515.159) we are not able to view linked testrail information. see screen print 
 testrails-issue.png

1 vote
Sergey Avtandilov
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 3, 2021

TestRail cookies maybe blocked by  local security policy at your organization

 Fix in Chrome: 

1. Open chrome://settings/cookies?search=cookie

2. Go to section "Sites that can always use cookies"

3. Add site as  [*.]testrail.io/

4. Re-open browser and visit Jira

Chris Kondov
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 30, 2022

Thank you, that fixed it for us!

1 vote
David Enriquez October 15, 2021

Hello everyone, 

Please also ensure that secure cookies are checked in the TestRail Administration settings. Administration > Site Settings. Multiple customers have reported this corrected the issues.

1 vote
Mednet Admin
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 1, 2021

Hi, 

 

Our teams started experiencing this problem today. It appears to be across all browsers. If someone finds a new solution please update as will I.

Joshua Walkowski
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 22, 2021

Only select members of my team are still experiencing this. We have tried the solution above related to changing chrome settings, but this does not work. So an answer here would be very helpful

0 votes
Ramakrishnan Hariharan June 25, 2024

We faced same issue and enabling "Force Secure Cookies" in Testrail resolved the issue without any browser workaround on all the browsers.

 

jira.png

 

Regards,

Ramki

0 votes
jspina
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
September 28, 2022

This solution worked for me on FireFox

Process on Firefox:

  • Go to Settings >> Privacy and Security
  • Click on Custom
  • de-select Cookies
  • a button will appear to "Reload All Tabs". Click it
  • note: You might need to manually reload your tabs, it wasn't my case.
Zoja Kubiskina
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
September 26, 2023

Same worked for me in Chrome - Privacy and Security > Third party cookies > remove tick from Block third-party cookies

0 votes
Viktoria Kholodenko
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 15, 2021

Hey, I have faced the same issue and tried the Disabled fix but it didn't help. Also, TestRail cookies have the same values @Sergei Nechai described before. I assume the root cause could be in TestRail SSO authorization. Did anyone have something like that? Did someone have any ideas on how to fix this?

Thanks in advance.

0 votes
Corefracture
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 1, 2021

FYI - The solution above will no longer work with latest versions of Chrome as they have defaulted those options to 'Enabled' and removed the settings :( 

Larry Sutton June 1, 2021

My Chrome just updated to Version 90.0.4430.212 (Official Build) (64-bit) when I checked the version. I have Disabled but I had disabled before the update. So it kept the setting this time.  Default, Enabled and Disabled are in the drop down.  I used the above path to check it.

0 votes
Larry Sutton January 12, 2021

The Disabled fix above works. However, it has to be reset periodically. Chrome seems to revert it to Default at some point. Seems for Chrome it is classified as experimental.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
AUG Leaders

Atlassian Community Events