Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Is there any way to hide rows from an excerpt table ?

I tried using Table Filter macro on top, but it seems that it doesn't work. Could you please advise?


Many Thanks!!

1 answer

1 accepted

1 vote
Answer accepted

Hi @Nesreen Saleh ,

Maybe you could provide your screenshots for us to better understand where is the problem?

Here is my basic example for you:

Tue 2-1.png

Tue 2-2.png

Or do you want to use the Table Excerpt macro inside the Table Filter macro? The new Cloud editor doesn't allow to nest several macros with bodies.

Hi @Katerina Kovriga _Stiltsoft_ ,

what I would like to do is to include part of the tables rows in a page, without the filter option. I don't want the users to see the below filter, I just want them when they access the page to be able to see some of the table rows.  Is there any way to hide this filter option?

Filter Option.PNGTHANKS A LOT!!

Hi @Nesreen Saleh ,

After you save the values for your filters (from the panel or via the macrobrowser settings), go to the macrobrowser -> Filtration tab -> scroll to the bottom -> Filters display mode and change it to the "Hidden".

As you can see on the preview, your panel will be hidden and your colleagues will see only the result table without any additional elements.

Mon 3-1.png

Mon 3-2.png

hi @Katerina Kovriga _Stiltsoft_ 


I tried to follow the following steps but it seems that it doesnot work as the whole content of the table are displayed

In the below example, I want to only show the B rows.

So, I filtered on the column 1 and I saved itScreenshot 1.png


Then, I selected "B" in the filter option and went to filtration tab and selected hidden display mode then I saved the changes, as shown below:Screenshot 2.pngScreenshot 3.png

Then I updated the page:

Screenshot 4.png


The result (as shown below) was that the whole table is displayed on the page.Screenshot 5.png



Not sure if I missed any step, So I would HIGHLY appreciate your advise on this issue.


Many Thanks!!

It seems to me that you tried to filter you B rows in the macro preview - and it is just a preview.

You should filter it via the "Set filters default values" - see your own second screenshot (its the first menu line under the "Ignore First N rows" empty field).

Hi @Katerina Kovriga _Stiltsoft_ , It works now :) THANKS A LOT for your support just another 2 questions in this example,

1) I would like to hide the inventory capabilities when it is displayed on the page. so, is there anyway to hide the name of the Page Containing the Excerpt : "Inventory Capabilities"?

2) Is it possible to hide columns, could I hide column 2 for example?

Screenshot 5.png

Hi @Nesreen Saleh ,

For the first question: please check what exactly do you have inside your Table Excerpt macro. Your Inventory Capabilities look more like a Panel macro to me or smth.

If I wrap only the required table into the Table Excerpt macro, then I get only this table via the Table Excerpt Include macro.

Mon 3-3.png

If you choose to add some metadata via the Table Excerpt Include macro, then the page name, space, labels, etc. are added as new columns, not like a big panel from the screenshot.

What concerns the second question: it is possible to hide unwanted columns. Go to the Filters tab and check the Hide columns option:

Mon 3-4.png

Then go to the Filtration tab -> Set filters' default values and choose the columns that you want to hide.

Mon 3-5.png

This should help your case.

@Nesreen Saleh , maybe you'll be interested to talk to our team via Zoom - not like a demo but more like interview where you'll be able to tell us about your use cases and we'll try to show you some tips how to solve them with the help of the Table Filter and Charts.

Please book the suitable time slot here - we'll be happy to meet you in person.)

Hi @Katerina Kovriga _Stiltsoft_ , 

Everything is working well now! I will get back to you whenever I face any other issue.

THANKS A LOT for your support and prompt response! I HIGHLY appreciate it :)

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events