Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Insight filter error Something went wrong. Contact administrator

Ok so for the last month or so i receive this error whenever i go to a particular insight "view" of the assets list. All other views work fine. I think i had added a column to the view or something that no longer exists. How do i fix this error? basically the insight list view is blank, and displays this error in a popup.

 

Is there someway to reset the view to default? ideally without breaking all the other customized views for my user?

It happens when i click on the "objects" button.

2 answers

With Riada's help, I've gotten to the bottom of my issue:  the root cause was that I had changed an attribute from Default/Select to Object.  This shouldn't be possible but in my case the object type I was modifying was an abstract object type that allowed inheritance, and all the data for the field was in the child object types.  Insight has a minor bug that fails to prevent the administrator (me) from making that change under those conditions.  They've now filed the bug internally and will address in a later release.

The solution was to find the attribute in the database and change its Type to 0 and Default_Type_Id to 10:

update  "AO_8542F1_IFJ_OBJ_TYPE_ATTR" set "TYPE" = 0, "DEFAULT_TYPE_ID" = 10 where "ID" = <the attribute's ID>;

The trick is to know which attribute you've changed.

If you don't want to deal with the database, the quickest solution is to just delete the offending attribute and create a new one from scratch, but in that case you'll lose data.

 

I don't know that my case is an exactly parallel to yours, though.  For me, the attribute in question wasn't appearing in my default view.

Cool. For me i just got fed up and deleted my jira cookie. That solved the issue but all must custom views are gone now. oh well.

How did you find out which attribute caused the exception? How do you create a new one?

Actually i never posted back but the main issue here was a bad record in the database. I kept getting an error whenever i went to one particular insight item. It would lock up the site and break all my views. I noticed that they were views that contained this one item that i knew i couldnt view but just ignored it.

I was able to somehow delete the insight item, but i forget exactly how now as it was over a year ago. After i deleted the bad data object, i never had the problem again with insight at all.


So could be just one bad row in your insight data. For me whenever i hit any view that contained that item, it would error out.

I'm having the same issue.  Jira 7.7.0; Insight 5.5.12.2.  

From /opt/atlassian/jira-data/log/atlassian-jira.log when I tried to click on the object type in question.

2018-08-15 15:45:46,780 http-nio-8081-exec-13 ERROR JHill 945x67878x1 1pomq9x 172.18.70.43,172.18.30.150 /rest/insight/1.0/object/navlist [c.r.j.p.i.c.w.a.r.exception.mapper.DefaultMapper] Unexpected exception was thrown while processing the request
java.lang.NullPointerException
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.transformation.RestBeanAssemblerImpl.assembleObjectAttributeValueEntry(RestBeanAssemblerImpl.java:1386)
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.transformation.RestBeanAssemblerImpl.lambda$assembleObjectAttributeValueEntries$180(RestBeanAssemblerImpl.java:1361)
        at java.util.ArrayList.forEach(ArrayList.java:1249)
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.transformation.RestBeanAssemblerImpl.assembleObjectAttributeValueEntries(RestBeanAssemblerImpl.java:1359)
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.transformation.RestBeanAssemblerImpl.assembleObjectAttributeEntry(RestBeanAssemblerImpl.java:1346)
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.transformation.RestBeanAssemblerImpl.lambda$assembleObjectEntry$179(RestBeanAssemblerImpl.java:1288)
        at java.util.ArrayList.forEach(ArrayList.java:1249)
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.transformation.RestBeanAssemblerImpl.assembleObjectEntry(RestBeanAssemblerImpl.java:1286)
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.transformation.RestBeanAssemblerImpl.assembleObjectEntry(RestBeanAssemblerImpl.java:1241)
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.services.ObjectResource.lambda$findObjectsByIQL$293(ObjectResource.java:669)
        at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1374)
        at java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:580)
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.services.ObjectResource.findObjectsByIQL(ObjectResource.java:668)
        at com.riadalabs.jira.plugins.insight.channel.web.api.rest.services.ObjectResource.findObject(ObjectResource.java:589)
        ... 2 filtered
        at java.lang.reflect.Method.invoke(Method.java:498)
        ... 19 filtered
        at com.atlassian.plugins.rest.module.RestDelegatingServletFilter$JerseyOsgiServletContainer.doFilter(RestDelegatingServletFilter.java:154)
        ... 1 filtered
        at com.atlassian.plugins.rest.module.RestDelegatingServletFilter.doFilter(RestDelegatingServletFilter.java:68)
        ... 32 filtered
        at com.atlassian.servicedesk.internal.web.ExternalCustomerLockoutFilter.doFilter(ExternalCustomerLockoutFilter.java:56)
        ... 13 filtered
        at com.atlassian.web.servlet.plugin.request.RedirectInterceptingFilter.doFilter(RedirectInterceptingFilter.java:21)
        ... 53 filtered
        at com.atlassian.jira.security.JiraSecurityFilter.lambda$doFilter$0(JiraSecurityFilter.java:66)
        ... 1 filtered
        at com.atlassian.jira.security.JiraSecurityFilter.doFilter(JiraSecurityFilter.java:64)
        ... 16 filtered
        at com.atlassian.plugins.rest.module.servlet.RestSeraphFilter.doFilter(RestSeraphFilter.java:37)
        ... 3 filtered
        at org.techtime.easysso.integration.filtering.PrincipalUserComponent.processPrincipalUser(PrincipalUserComponent.java:168)
        at org.techtime.easysso.logic.FullyEnabledStrategy.doPrincipalFiltering(FullyEnabledStrategy.java:144)
        at org.techtime.easysso.interfaces.JespaPrincipalFilter.doFilter(JespaPrincipalFilter.java:32)
        ... 3 filtered
        at org.techtime.easysso.logic.FullyEnabledStrategy.doX509Filtering(FullyEnabledStrategy.java:93)
        at org.techtime.easysso.interfaces.X509Filter.doFilter(X509Filter.java:30)
        ... 19 filtered
        at com.atlassian.jira.servermetrics.CorrelationIdPopulatorFilter.doFilter(CorrelationIdPopulatorFilter.java:30)
        ... 5 filtered
        at com.atlassian.servicedesk.internal.web.CustomerContextSettingFilter.lambda$invokeFilterChain$0(CustomerContextSettingFilter.java:181)
        at com.atlassian.servicedesk.internal.api.util.context.ReentrantThreadLocalBasedCodeContext.rteInvoke(ReentrantThreadLocalBasedCodeContext.java:137)
        at com.atlassian.servicedesk.internal.api.util.context.ReentrantThreadLocalBasedCodeContext.runOutOfContext(ReentrantThreadLocalBasedCodeContext.java:90)
        at com.atlassian.servicedesk.internal.utils.context.CustomerContextServiceImpl.runOutOfCustomerContext(CustomerContextServiceImpl.java:47)
        at com.atlassian.servicedesk.internal.web.CustomerContextSettingFilter.outOfCustomerContext(CustomerContextSettingFilter.java:174)
        at com.atlassian.servicedesk.internal.web.CustomerContextSettingFilter.doFilterImpl(CustomerContextSettingFilter.java:130)
        at com.atlassian.servicedesk.internal.web.CustomerContextSettingFilter.doFilter(CustomerContextSettingFilter.java:121)
        ... 4 filtered
        at com.atlassian.jwt.internal.servlet.JwtAuthFilter.doFilter(JwtAuthFilter.java:32)
        ... 8 filtered
        at com.atlassian.web.servlet.plugin.request.RedirectInterceptingFilter.doFilter(RedirectInterceptingFilter.java:21)
        ... 4 filtered
        at com.atlassian.web.servlet.plugin.LocationCleanerFilter.doFilter(LocationCleanerFilter.java:36)
        ... 3 filtered
        at org.techtime.easysso.integration.filtering.JespaComponent$FilterChainWrapper.doFilter(JespaComponent.java:635)
        at jespa.http.HttpSecurityService.doFilter(HttpSecurityService.java:1596)
        ... 2 filtered
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.techtime.easysso.integration.filtering.JespaComponent.invokeMethod(JespaComponent.java:605)
        at org.techtime.easysso.integration.filtering.JespaComponent.doFilter(JespaComponent.java:552)
        at org.techtime.easysso.logic.FullyEnabledStrategy.doNTLMFiltering(FullyEnabledStrategy.java:59)
        at org.techtime.easysso.interfaces.JespaFilter.doFilter(JespaFilter.java:74)
        ... 26 filtered
        at com.atlassian.jira.servermetrics.MetricsCollectorFilter.doFilter(MetricsCollectorFilter.java:25)
        ... 23 filtered
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
        at java.lang.Thread.run(Thread.java:745)                                                          

i think a quick fix is to delete your browser history and cache and saved cookies, etc... but i havent wanted to do that. it does not occur in other browsers.

 

I havent done the "nuclear" option because i was hoping there was a better way. But that might easily fix your problem if its just your one client and browser having the issue.

 

I think asset "views" are stored in the browser.

Great idea, but I can reproduce the issue by switching from IE to Chrome.  I *was* able to get one of the five affected object types (all children of the same parent object type) to display by reindexing, but that didn't seem to do anything to the others.

Like patriknetent likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

5 mobile apps for Jira Cloud to boost productivity

  It’s very important to have access to the workflow process from anywhere. Especially if you manage the work of others. There is no difference whether you’re out of office, or drive a ca...

265 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you