Insight database import into Unlimited cardinality field

Chad Peters January 9, 2018

When using the database import type, I'd like to map one of my column values to an Insight field that has Unlimited Cardinality defined. How does the source data need to be formatted for this to work (comma separated values, semi-colon)??

2 answers

1 accepted

0 votes
Answer accepted
Alexander Sundström
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
January 10, 2018

Hi Chad,

The way Insight works is that you separate those values with || ie:

value 1||value 2

That way it will be imported as multiple values. If this is used to create object references, you will need to apply certain IQL syntax, which you can read about at https://documentation.riada.se/insight/latest/insight-manager-s-guide/import-and-synchronization/general-import-concepts under the section Import attribute / Object Mapping (IQL) where there is also a video demonstrating how to set this up. It's based on an CSV import, but the way it works is the same.

Best Regards
Alexander 

Micha March 20, 2018

This doesn't work for me. I am trying to do this to create object references, with the correct IQL.

So when I put person A||person B in my CSV file I expect two objects, but now I get one object.

Expected object names:

person A

person B

Actually:

person A-person B

Can someone help me please?

Alexander Sundström
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 21, 2018

Hi Micha, are you trying to create the referenced objects, or assigning them from already created Insight objects?

Cheers!
Alexander

wheazel
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 12, 2018

Have the same problem:

CSV: firstname;lastname;Account1||Account2;

result: Account1-Account2 (1 Object)
instead of:

Account1
Account2
(2 Objects)
I am creating the accounts during Userimport. Works fine with 1 account, but 2 or more accounts are merged into a single object with the default concatenation character as required in the import settings.
What I want to do is tell the system, that these are 2 different Objects that should be created.

Serge_tkint September 27, 2019

yup, got the same question: What about multiple objects import to an "unlimited cardinality" 
Not like the provide answer where they are concatenated

Dimitri Cools June 4, 2020

same question here !

Jenny Severin January 19, 2021

Same question

0 votes
David Wimbush September 16, 2021

Hi, 

I managed to get this working via the below approach.

Objective

Map 2 items as separate objects in the same field 

i.e.

|Colours|

|'Red', 'Blue'|

Solution

In your input file, the items that are to be separated need to be split by || (2 pipes) 

a || b

On the target column configuration, I used the Select option (Default --> Select) and chose maximum cardinality

Run the import and this should do the trick! 

Hope this helps! 

Thanks,

Dave W 

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events