Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,868
Community Members
 
Community Events
168
Community Groups

I need to downgrade the ZAPI add-on for my Jira server 7. the existing version is incompatible

I need to downgrade the ZAPI add-on my jira server due to incompatible.

Please advice me on how to downgrade this add-on.

Need to downgrade from "2.7.1.27107788" to "2.7.1.27107787"  

1 answer

0 votes

Go to the marketplace entry and head for downloads.  Find the version you want, download it to your machine, then go to Jira -> Admin -> Manage apps, remove the existing Zapi app, then use "upload app" to add the file you downloaded.

Removing the existing app will cause any actions , do we need to take any precaution or backup?

I would always back up, before something like this.

But I would not anticipate there being any problems.  The worst case is that you have ZAPI data that is not in the shape the older version of the plugin understands, which may stop it working properly, but you won't lose any data.

I'm curious as to how you got to an incompatible version of Zapi though - if you'd used "manage apps" to install/upgrade Zapi, you would not have got an incompatible version installed.

While installing the ZAPI plugin the latest version got Installed. 
Installed version is "2.7.1.27107788" it said is incompatible.

we have check that "2.7.1.27107787" is compatible to our Jira server 

can't we do revert without uninstalling or removing the existing plugin?

I still have to question that.  If you used "manage apps" to install the plugin, it would not have installed an incompatible version.

You can only install incompatible versions by deliberately downloading them and manually installing them (as per method given for "downgrade")

Anyway, yes, you do not need to disable or uninstall the existing one.  The new one will destroy it anyway when you upload it.  I prefer to uninstall first because there are a couple of apps that give you some information when you uninstall.

I am not sure on the Incompatible version installed but some how it was done.have to investigate on that.

  • Regarding the reverting the older version of the plugin.
    I uploaded the desired "obr" file in the manage apps. But it did not reflect any thing and still see same version.
  • I observed in the plugin installation directory I see both "obr" files and I have rename the existing one and restart the jira service.
  • it reflected with desired plugin version. and did the system re-index.


    I did this on my test machine but is this method is recommended in prod ?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events