It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I added a script fragment, but now I'm not able to edit or delete it

Charlie Bolante Dec 12, 2017

I've create a script fragment (raw xml module and custom web item provider), now I'm not able to edit or delete any of the ones that I have create.

When I click on the setting cog icon, nothing happens. There are other script fragments like "Hide system or plugin UI element" that allow me to edit, but I now get the following error:

The web item provider class is required.: <web-item-provider key="internalissues-web-item-provider" section="toppy/top-menu-section"/>

com.atlassian.plugin.util.validation.ValidationException: The web item provider class is required.: <web-item-provider key="internalissues-web-item-provider" section="toppy/top-menu-section"/> at com.atlassian.plugin.util.validation.ValidationPattern.evaluate(ValidationPattern.java:66) at com.atlassian.plugin.descriptors.AbstractModuleDescriptor.validate(AbstractModuleDescriptor.java:170) at com.atlassian.plugin.descriptors.AbstractModuleDescriptor.init(AbstractModuleDescriptor.java:72) at com.atlassian.plugin.web.descriptors.WebItemProviderModuleDescriptor.init(WebItemProviderModuleDescriptor.java:42) at com.atlassian.plugin.ModuleDescriptor$init$3.call(Unknown Source) at com.atlassian.plugin.ModuleDescriptor$init$3.call(Unknown Source) at com.onresolve.scriptrunner.fragments.FragmentsManager.register(FragmentsManager.groovy:248) at com.onresolve.scriptrunner.fragments.FragmentsManager.register(FragmentsManager.groovy) at com.onresolve.scriptrunner.fragments.IFragmentsManager$register$0.call(Unknown Source) at com.onresolve.scriptrunner.canned.common.fragments.CustomRawXmlDescriptorScript$_doScript_closure2.doCall(CustomRawXmlDescriptorScript.groovy:109) at com.onresolve.scriptrunner.canned.common.fragments.CustomRawXmlDescriptorScript.doScript(CustomRawXmlDescriptorScript.groovy:103)

No other apparent errors showing in log.

 

1 answer

1 accepted

1 vote
Answer accepted

Hello Charlie

You might be suffering from a know bug that arises when you create two fragments that are exactly the same:

https://productsupport.adaptavist.com/browse/SRPLAT-217

If you are, there is a workaround in that very bug to solve your problem.

Cheers!

Dyelamos

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted in Marketplace Apps & Integrations

Demo Den Ep. 4: Continuous Integration with CircleCI & Jira Software

Get ready! Demo Den Episode 4 is coming your way on Tuesday, May 28, 2018 with a Continuous Integration and Delivery special demo. CircleCI Director of Solutions Engineering, Eddie Webb will show us ...

486 views 0 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you