Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

How to use {{comment.internal}} on Automation for JIRA

I want to use


while using Automation for JIRA in order to only send an email if a comment is external. However I tried using the compare condition parameter within the add on and that is throwing an error as it resolves to:

{{comment.internal}} = false

false = false 

Not sure how I can test whether it's true or false before firing an email event. 

Could someone point me in the right direction? I'm stuck! :)



3 answers

2 accepted

7 votes
Answer accepted

Hey there Hollie,

What you have there should work. Are you using the compare condition? You'll want to have it look something like:


Hope that helps! If not can you post a screenshot of your config?


Mark C

Hi Mark, 

It comes back and says it doesn't match even when I put an external comment on the ticket. The Audit log shows this: 


Action details:

JQL condition

The following issues passed:IT-1292

Compare condition

The following issues did not match the condition:IT-1292


My screenshot looks exactly like yours does above :( 







I had a space in front of the first {{ - removed that and it worked like a charm!

4 votes
Answer accepted

I had a space in front of the first {{ - removed that and it worked like a charm!

0 votes
Rob Horan Community Leader Dec 23, 2021

Why isn't this an out-of-the-box option for comment-based triggers?

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events