It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I uninstall the atlassian visual studio 2012 connector?

After installing it my VS has really slowed down, and I would like to uninstall it, but I can't figure out how.

10 answers

1 accepted

1 vote
Answer accepted


Have you tried disabling issue links scanning in the general settings dialog? This makes the connector stop trying to parse source files and should increase responsiveness of Visual Studio.

If you really want to uninstall the connector, you can do it from the computer's control panel ("Add/Remove Programs")


I'll try disabling the issue scanning.

The connector doesn't show in add/remove programs. Which is why I'm having such a hard time uninstalling it.

Although still unable to uninstall. It seems to be a moot point now. It would appear that turnning of the parsing has fixed my slowness. Thanks for all your help.

hmm, it looks like you already uninstalled the connector, but somehow not all files got removed. Could you install the connector again and then uninstall?

Thanks for your help so far..

Okay so I reinstalled it, and it showed in the control panel. I closed all instances of VS and uninstalled it from there. Opened visual studio and it was still there. So I reinstalled it again, and this time I uninstalled it from the program files folder, and I ran the uninstallation as an administrator. Opened VS, still there.

you can try "C:\Program Files (x86)\Atlassian Connector For Visual Studio\uninstall.exe"

The only thing in that folder is a png file.

Can you try manually removing "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\Extensions\Atlassian\Atlassian Connector" folder?

Sadly, no good. When I did that I got error messages when opening my solution, and I couldn't see any code anymore.

At this point, I think that I'll have to completely do a full unistallation of visual studio and do a clean install. Hopefully, turning off the parsing will help. Because I won't have time to do this for a while.

what was the error message?

An exception has been encountered. This may be caused by an extension.

You can get more information by examining the file 'c:\uers\jsosa...'.

Can you run visual studio with a /log option and send me the log file? Its location is described in (substitute 9.0 version with 11.0 in the path)

How do I send you the log file. Also, I have a meeting in 5 minutes, so it may be a while.

I've generated the file already, but it's too big to paste here.

I also had this problem, except I would get a warning (Yes/No dialog with a yellow triangle and exclamation mark):

The 'Atlassian.plvs.PlvsPackage, plvs2010, Version=, Culture=neutral, PlublicKeyToken=null' package did not load correctly.


This is after attempting to uninstall from Tools > Extensions and Updates, then from the Windows Add/Remove programs dialog, then by Deleting the C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\Extensions\Atlassian folder.

I took a look at the log (C:\Users\[user]\AppData\Roaming\Microsoft\VisualStudio\11.0\ActivityLog.xml), and found the GUID for the extension, which upon a registry search, led me to the following keys:

  • HKEY_CURRENT_USER\Software\Microsof\VisualStudio\11.0_Config\Packages
  • HKEY_CURRENT_USER\Software\Microsof\VisualStudio\11.0_Config\InstalledProducts\PlvsPackage
  • HKEY_CURRENT_USER\Software\Microsof\VisualStudio\11.0_Config\IssueRepositoryConnectors
  • HKEY_CURRENT_USER\Software\Microsof\VisualStudio\11.0_Config\Menus
  • HKEY_CURRENT_USER\Software\Microsof\VisualStudio\11.0_Config\ToolWindows
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\11.0\InstalledProducts\PlvsPackage
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\11.0\IssueRepositoryConnectors

I carefully removed keys and values related to the extension, and I no longer get the error when starting Visual Studio.

I had this same problem. I had to follow the instructions to remove registry keys to fully get rid of the connector.

I tried following the steps above and I still ran into issues. So this is what I did.

Step 1: Install "revo unistaller"

Step 2: reinstall atlassian connector

Step 3: user revo to uninstall the connector

Revo goes through the registry and filesystem to remove any leftovers.

It worked perfectly for me.


I have just released version 1.3.11 of the connector. When you install it, it uninstalls properly from VS 2012 (and 2013 too)

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Marketplace Apps & Integrations

Expose your beautifully crafted Dashboard through the Jira Service Desk Customer Portal

  A picture is worth a thousand words, especially when you're trying to find relationships and understand your data. Here, Dashboards play a vital role in gaining insights from a variety of dat...

286 views 5 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you