Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,360,948
Community Members
 
Community Events
168
Community Groups

How do I track two fields in the Confiforms Rules for Field Definition Field Name box?

I have 3 fields:
TypeofWork
ImpactedPGs
podTeamName

I want to hide podTeamName unless TypeofWork:8 AND ImpactedPGs:PST

In Field Name I have - TypeofWork, ImpactedPGs
In Condition I have - !TypeOfWork:8 and !ImpactedPGs:CEPSPST

Is this doable or some addition setting I should be setting in the macro?
Or did I mis-read (https://wiki.vertuna.com/display/CONFIFORMS/How+to+show+and+hide+fields+in+the+form+conditionally) where it seemed to say that this could work?

1 answer

1 accepted

Hi

You shall put the condition when you want to HIDE the field, right?

So, it should be

TypeofWork:8 AND ImpactedPGs:PST

And obviously in the rule you need to set the field you want to hide

Alex

Hi Alex,

Thanks for your response. Yes, I'm using AND vs and. I've changed the rule to a Show vs Hide again to see if I can get it working. Also, I'm not a dev but one of those 'dangerous' business users :)


I have a couple hide rules that impact this field.
1. Hide if the user isn't logged in - users have to be logged in so check if the email field is pre-filled via the Reg Control (Email=[user.email]) and a bit of javascript (not mine) before show any other fields on the form
2. Hide if TypeOfWork:[Empty] - users have to select an option to see the related fields
3. When the user picks type 8 Show the related fields - podteamname is not in the list to fields to show. I've set this to a Hide rule
4. Show podteamname when type is 8 and team is PST - this is the last rule in the order of rules

The field shows up but not consistently to meet the criteria.
If TypeOfWork:8 is selected and then ImpactedPGs:PST is selected the field doesn't show but if I keep ImpactedPGs:PST selected and set TypeofWork back to empty (picking the blank in the TypeofWork dropdown) or select another Type and then select TypeOfWork:8 the podteamname field shows up.

Any ideas what I'm missing?  Is the content in the Fieldname box allowed? Also not sure if that checkbox should be selected.

podteamname.png

Hi

It's hard to advise anything without knowing the whole configuration. Most obviously you have a conflicting rule that interferes

Try removing the rules that you have to see how things work. and then start adding these rules back. To understand which one breaks the logic and starts to conflict

Alex

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

Apps for Confluence you won't want to miss: RSVP for September's Appy Hours

Calling all collaborators and Confluence users! Our Appy Hours event on September 29th features 4 presenters demoing functionality to superpower Confluence. Don't miss learning about these apps i...

118 views 0 9
Read article

Atlassian Community Events