Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Help creating a subtask link to the parent issue

Hi,

     I would like your help in order to know why I am receiving the following error by using the Console on Jira Service Desk on Script Runner APP. 

I am creating a subtask and then link this one the to the parent but I have tried to test several solutions over the web and cannot get the root cause of the error I am getting:

Code: 

//Libraries
import com.atlassian.jira.component.ComponentAccessor
import com.atlassian.jira.issue.MutableIssue
import com.atlassian.jira.config.SubTaskManager
import com.atlassian.jira.issue.Issue

//Variables definition
def user = ComponentAccessor.getJiraAuthenticationContext().getLoggedInUser()
def issueFactory = ComponentAccessor.getIssueFactory()
def subTaskManager = ComponentAccessor.getSubTaskManager()
def constantManager = ComponentAccessor.getConstantsManager()
def issueManager = ComponentAccessor.getIssueManager()
Issue parentIssue = issueManager.getIssueObject('Jira-21')
def subTaskSummary = parentIssue.getSummary()
Map params = new HashMap()

MutableIssue newSubTask = issueFactory.getIssue()
newSubTask.setSummary(subTaskSummary)
newSubTask.setParentObject(parentIssue)
newSubTask.setReporter(user)
newSubTask.setPriorityId(constantManager.getPriorities().find {
it.getName() == "Low"
}.id)
newSubTask.setProjectObject(parentIssue.getProjectObject())
newSubTask.setIssueTypeId(constantManager.getAllIssueTypeObjects().find{
it.getName() == "Feedback"
}.id)
// Add any other fields you want for the newly created sub task
log.debug("New issue ${newSubTask}")
params.put("issue", newSubTask)
//Map<String,Object> newIssueParams = ["issue" : newSubTask] as Map<String,Object>
Issue subtask = issueManager.createIssueObject(user, params)
ComponentAccessor.subTaskManager.createSubTaskIssueLink(parentIssue, subtask, user)
//subTaskManager.createSubTaskIssueLink(parentIssue, subtask, user)
log.info "Issue with summary ${newSubTask.summary} created"

 

The error I am getting is always:

2020-09-15 21:29:07,228 ERROR [common.UserScriptEndpoint]: ************************************************************************************* 2020-09-15 21:29:07,228 ERROR [common.UserScriptEndpoint]: Script console script failed: java.lang.NullPointerException at com.atlassian.jira.issue.link.DefaultIssueLinkManager.getIssueLink(DefaultIssueLinkManager.java:381) at com.atlassian.jira.issue.link.DefaultIssueLinkManager.createIssueLink(DefaultIssueLinkManager.java:89) at com.atlassian.jira.config.DefaultSubTaskManager.createSubTaskIssueLink(DefaultSubTaskManager.java:443) at com.atlassian.jira.config.SubTaskManager$createSubTaskIssueLink.call(Unknown Source) at Script163.run(Script163.groovy:33)

 

The subtask is being created properly with all values I set but the link is the one that is not working.

I have invested several time looking for solutions but the ones I have tried over the internet are not working. 

Script Runner version: 6.9.1

Jira Server version: 8.8.1

Thank you in advance for your help about it because I am getting at the end of the wall :s

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Do Not Lose your Customer’s Trust

Missing deadlines is one of the biggest problems every team lead wants to avoid when dealing with managed services. When the customer contracts your company to help with IT services it is expected th...

340 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you