Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,304
Community Members
 
Community Events
168
Community Groups

Having trouble with Microsoft Teams connection

So, I connected Jira Cloud to my Teams channel/space, had my Jira admin install the "Microsoft Teams for Jira Cloud" to our Jira instance, however when I then sign in using my SSO creds I get a "502 Bad Gateway" error.

 

Anyone else encounter this and know how to fix?

5 answers

I had the same error, and tried opening the Jira integration in the browser version of Teams. It worked correctly and then I could open it from the desktop app as well. Maybe this helps?

This workaround worked for me.

For me this worked when I tried it from MS Edge. For Chrome I got the 502 Bad gw.
As for you, once I got it to work through Edge, it started to work in the Teams app too.

Hi Is the problem fixed?

We also facing this problem.

Elena's suggested workaround worked.

Capture1.JPGI'm also having this problem

we are also facing same issue, 502 Bad Gateway

When using Teams on the browser (not Windows app), the 502 bad gateway error doesn't come up. Please try that option.

We use Okta for SSO and it won't work in the desktop Teams app but the earlier noted workaround does resolve when performed in the web app.  Is Atlassian monitoring this thread?

I have tried it from the browser and there I had the same error so for us does not work nor in the native app nor from the browser. 

 

Some help would be appreciated.

Like Adriaan Bastien likes this

Also experiencing the same problem :(

For me this worked when I tried it from MS Edge. For Chrome I got the 502 Bad gw.
As for you, once I got it to work through Edge, it started to work in the Teams app too.

So trying this in a few different browsers could work.

I'm experiencing the same issue. Any solution yet ?.

Issue was fixed, not sure if it was from Soft Serve or the glitch worked itself out...but I can now reference/edit/search for issues from our Jira instance.  Pretty slick now that it works!

Thanks for the quick reaction but for us it does not work we use the Single Sing On option (with Microsoft account) to our atlassian cloud and when I'm trying to connect the jura app from teams to the teams plugin in jura during login I get bad getaway error Screenshot 2020-09-04 at 13.34.35.pngSo for us the probem still exists.

Yep that's exactly what we were seeing then was magically fixed.  You probably already checked, but did you also install the Teams package on the Jira side first?

Suggest you follow the above recommendation and perhaps they are addressing on a case by case basis for each company/org?

https://www.softserveinc.com/en-us/msteams-atlassian-privacy-policy

@Richard Szabo - I'm also still getting the 502 error when logging in via SSO. 

0 votes

Hi @jconnors224 ,

Please contact our support team by going to the following link https://www.softserveinc.com/en-us/msteams-atlassian-privacy-policy and filling in the form provided there, so we could resolve the issue for you and prevent anyone else from encountering the same problem.

Best regards,

SoftServe Support Team

Will do, thanks!

I'm also having this problem. Was a fix identified?

Not yet, @Josh Patrick .  I opened a ticket with Soft Serve and it was transferred to another group acknowledging awareness of the issue and it's being worked

Like Josh Patrick likes this

@SoftServe Support is there any update on this issue please?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS

Atlassian Community Events