Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Has anyone had any experience with the Azure Import module for Insight?

I am attempting to test out the Azure Import module that you can download for Insight, but not having a lot of success. I can get the import setup following the documentation on Mindville's website and the test config is successful. But when it gets to setting up the configuration, I get stuck.

I tried having Insight create the predefined configuration. That just spun all night long and never seemed to produce anything. When I try and manually create the config, it doesn't find anything for the data locator.

Just looking to see if anyone else has had struggles with trying to import Azure information into your CMDB or what tricks they might have found.

Thanks in advance!

1 answer

Hi Rob, have you had any success in the meantime or have you given up your attempts?

I'm trying to get the import module running, but the test connection has already failed.

I am happy about every helpful hint

Bjoern,

 

Yes, I did end up having success. But only after Mindville was able to make some updates to their software. It appeared to be having some kind of java issue and would time out. After they gave me a new version (which is older than the currently released version), then it all worked out great.

When you mention the test connection is failing, are you talking about during the setup where you can test the connection, after you enter all of your application IDs, subscription IDs, etc.?

HI Rob,

thanks for the feedback. Yes I am talking about the setup where I add subscription directoiry application id and secret.

Meanwhile I am waiting on our Firewall guys checking if the requested rules allowing the server going outside to azure are implemented as requested. If in the end this was the issue, a pity about the time, but the certainty to have done everything right is also ok.

In the end did the module meet your requirements? My goal is to read the data from our Intune managed mobile devices (cellphone, tablets) and import it into Insight. 

Bjoern,

Funny you mention InTune. I am just starting to attempt that portion. I have so far just been using it for my VMs, subscriptions, NSGs, etc.

I did one pass at InTune and it did not work very well in terms of bringing in the InTune devices. I reached out to Mindville and they told me 2 things. One, I needed to setup the Azure Graph Data, which I did not realize would be needed for InTune. The other item, they had to provide me with a beta version of the Azure import module as Microsoft recently moved the InTune management from the normal azure portal over to their new Endpoint Manager Center, or whatever it is called.

I haven't went in and setup the graph data yet to try out the beta release they gave me. So I am guessing even if your firewall gets sorted out, the InTune devices might not come in right until they release their new version. But that is just a guess at this point.

Hi Rob,

it ended up as a firewall issue. Our network team implemented required rules for the "insight" server incomplete. Now I was able to complete the setup and connect successful to Azure.

With the current release 1.7.2 I successful fetched the data from Intune. I think documentation about required Azure Graph Data had been updated recently too.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

🍻🍂Apptoberfest Update: Upcoming Virtual Events 🎉

Hello Community! I hope you've been enjoying the 🍂Apptoberfestivities🍂 (I know I have!) The event is heating up next week with a series of virtual events that we're calling the 🍻🍂Partner App ...

620 views 7 23
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you