Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,527
Community Members
 
Community Events
168
Community Groups

Figma file preview not showing

It has been set up in my team's jira tasks that we can attach Figma links to showcase our design work. Ever since this week, the Figma preview is not showing on my screen.

I can attach the Figma link with no problem, but it's showing that I need to log in to my Figma account to see the preview. Every time I try to log in, a gateway would pop up for a second & then it disappears immediately. Keep in mind, this scenario is happening while I'm already logged in to my Figma desktop app, and I can also still click the "Open in Figma" button & open the file in browser with no problem.

Is this a bug? my co-worker can see the same figma file preview on her screen, but it's not showing for me. Help!Screen Shot 2020-08-07 at 16.38.36.png

7 answers

0 votes

It's 2022 and this still hasn't been fixed. The designs do load eventually, but it takes between 5 and 10 minutes to load each time you open a ticket! This has been broken since I can remember.

On Linear the figma preview loads within seconds of opening a ticket. Can this please be given some attention Jira?

0 votes

I tried to put my figma link in jira, but it never works.

I am having this exact same problem in 2022. The Figma plugin does not work in Trello, in Safari.

I am using Safari on an M1 Mac mini. The Figma preview doesn't appear, and there's not even a link to fallback on. I've tried the same thing in Chrome, and the preview does appear there, but I don't want to use a Chromium based browser just for Trello + Figma.

More than a year later and I can confirm the Issue still exists (MacBook Pro, latest Browsers: Chrome, Safari, Firefox doesn't even bother to show anything)

I can also confirm that the troubleshooting advices given on August 2020 don't work.


When inspecting the Jira page in Chrome I get this Info in the console:
Booting Figma JIRA integration for issueKey xxx
issue-panel.js:323 [test] FigmaAddon.destinationForURLOpen for invalid URLs passed
issue-panel.js:323 [test] FigmaAddon.destinationForURLOpen for file URLs passed
issue-panel.js:326 [test] FigmaAddon.destinationForURLOpen for proto URLs failed with error Remove URL parameters when opening in INSPECT mode since they may not apply to /file links
issue-panel.js:201 GET https://www.figma.com/file/xxx 404

PLease get this fixed.

I have the same problem, but for me happens only in Safari. In Chrome works ok, but this should work regardless of the browser. It drives me nuts, because my main browser is Safari.

I have the exact same issue. It won't load the design in Safari and I don't know why. I'm logged into Figma from the browser. I tried enabling pop-ups, still in vain. Nothing works.

@Petter Gonçalves I'm experiencing the same issue that Jessica reported. I've tried the troubleshooting steps that you suggested but they did not resolve the issue.

Hello @Jessica Tan

Welcome to the Atlassian Community!

I believe that you must be logged to Figma directly in your browser to allow the app to get the login credentials and properly preview the files in your Jira. Additionally, it is possible that your browser is blocking the pop-up from Figma when you click to log in directly from the issue view.

Please, try the steps below to properly troubleshoot the problem:

  1. Try to log in to your Figma account in a separate tab of your browser. Then, wait 30 seconds and open/refresh the issue view again to check if the preview is displayed
  2. Check if your browser is not blocking any pop-ups and try to login from the issue view again: 
    Chrome: Block or allow pop-ups in Chrome 
    Firefox: Pop-up Blocker settings 
    P.S If you are using a different browser, navigate to Google and type "allow pop-ups" and your browser name to get the proper instructions. 
  3. Try to use your browser in incognito mode and clear your browser cache, so we can ensure there are no extensions causing the problem
  4. Try to use a different browser, applying all the steps above. Preferably, use the same browser (in the same version) that your colleague is current using, where the problem is not happening

Additionally, I added this question with the correct tags so the support team from Figma can also check and suggest any other steps to troubleshoot the issue.

Let us know if you have any questions.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS

Atlassian Community Events