Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Field Script Runner: 'issueFunction' does not exist or this field cannot be viewed by anonymous users."

I am facing this issue as well. As suggested I have made sure the scheme context is set to Global mode.

It didn't solve my issue and keep getting the same error. By the way I am using JIRA rest API services with curl.

The exact error is, "Field 'issueFunction' does not exist or this field cannot be viewed by anonymous users."

The JIRA project is open to all and hence anybody can view all the issues inside this project. Also I am able to access all the issue fields anonymously without any issue. It is only when I use this script runner's 'issueFunction' throwing the authentication issue.

 

Any help is really appreciated.

3 answers

1 vote

issueFunction is not a field, it's a JQL function in script runner.  Could you show us the JQL you are using it in?   Is the Scriptrunnner fully enabled, and is the scripted-functions module enabled?

Thanks Nic for your reply. This is the command I am using,

curl -D- -H 'content-type:application/json' -X POST -d '{"jql":"issueFunction in issueFieldMatch(\"project=FOO\",\"Version Found\",\"13.2_\")","fields":["summary","status","assignee"]}' http://XXX/rest/api/2/search

{"errorMessages":["Field 'issueFunction' does not exist or this field cannot be viewed by anonymous users."],"errors":{}}

I didn't get when you meant 'fully enabled'. I think the Script Runner plugin is enabled as I see the 'issueFunction'  shown in my list of custom fields.

In the 'Script JQL Functions' page I see a list of functions that said are enabled and the function I have used in this example 'issueFieldMatch' is among them.

 

What happens when you run identical JQL in the UI?

I get the results without any issue.

Ok, then that suggests that you are logging in as a different user under REST and that user is not able to view the project.

No for REST I am running anonymously and that is evident from my curl command above.

People often drop the username/password when posting here for security reasons, or you could have been using cookies. Anyway, that's the answer - you need to log in as a user who can see the project

This same error message is encountered, even with everything set up correctly, if it is a new user who has never logged in before. Manually logging in with the same account in the web browser just once resolves the symptoms. Subsequent script runs will now succeed.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

New Cloud Apps Roundup - April 2021

Atlassian's marketplace partners have had a very productive start to 2021! Since our last roundup, our developer community has added over 160 new cloud apps to the Atlassian Marketplace to help you...

317 views 3 20
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you