Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Display footnote macro no longer working

All pages where the display footnote macro is used are no longer working and show the error message:

Error: No group with name {footnoteId}

instead of the page content.

Removing the macro shows the content as expected.

We are using:

- Confluence server: 6.1.3

- Adaptavist footnote plugin: 2.6.0

Please, help fixing this issue ASAP.

2 answers

1 accepted

0 votes
Answer accepted
Thomas Schlegel Community Leader Jun 06, 2017

Hi Rosario,

do you also have the Content Formatting Plugin from Adaptavist? And installed the latest version?

With version 6, they deployed a new footnote macro with that Add on and disabled the old one automatically.

Yes, I have also that plugin. This must be the reason. I missed any hint from Adaptavist on this chage...

Can you explain me how can I fix the issue then?

Thomas Schlegel Community Leader Jun 06, 2017

Is the new footnote macro enabled? Maybe the installation stopped the old one and not enabled the new one?

There is an announcement for that:

http://www.adaptavist.com/w/update-footnotes-for-confluence-users/ 

 

Well, the update of Content Formatting to v. 6.0.0 did not work as described in the link.

I have both plug-ins and after the upgrade the Footnote plug-in is still "active" but gives the metioned error and I the Content Formatting plug-in seems not to bring-in the new macros.

I tried to manually disable the Footnote plug-in but this results in "unknown macro" messages in all pages using the plug-in and if I edit the page I find no macro for footnote...

Who can help fixing the issue?

I have opened a support ticket.

Thanks for pointing out our product support @Thomas.

I've solved the issue with Rosario. Essentially for some reason the Footnotes modules were disabled.

After enabling the modules it worked perfectly.

Thomas Schlegel Community Leader Jun 08, 2017

great, you're welcome :-)

For sake of completeness, the solution was:

1. disable the Footnote plug-in

2. enable the footnote components in the Content Formatting plug-in manually.

Even if before this we had to do other actions and restart the server; probably this was not needed but we will never know...

Like Fred Bunting likes this

Hello @Rosario De Domenico  , @Thomas Schlegel  ,

Up for this topic, as I am facing the same issue:

  • In General Admin / Manage apps:
    • "Office Connector" is enabled
    • "Content Formatting for Confluence" is enabled
  • In General Admin / Office Connector settings, "Use the footnote macro for Word footnotes" is checked
  • In a wiki space, I click "Import Word document" / Choose file / Next / ...
  • The Word document is imported in a page, but I get "unknown macro {footnote}" where every footnote is expected to be displayed

=> However, the footnote macro is enabled via the Content Formatting for Confluence plugin.

In your earlier posts, you indicated there is the "Adaptavist footnote plugin": do I need to use it in addition? I don't think so, as I can't find it in the Marketplace. I suppose it has been integrated in the "Content Formatting for Confluence", right?

 

Thanks in advance for your feedback.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

🍻🍂Apptoberfest Update: Upcoming Virtual Events 🎉

Hello Community! I hope you've been enjoying the 🍂Apptoberfestivities🍂 (I know I have!) The event is heating up next week with a series of virtual events that we're calling the 🍻🍂Partner App ...

321 views 3 14
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you