It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Copying Test Steps across different test cases in Zephyr

Is there a way that i can copy test steps from 1 test case to another?

As similar test steps are used in a number of test cases so it would be really helpful to copy test steps. There is a cloning option for test cases but when the requirements are continuosly changing you have to sometimes change the test steps too.

Cloning test cases wouldnt help in that case as you dont want a new test case but want to change the test steps in the existing test cases so if there is a copy test step option that could help.

2 answers

1 accepted

4 votes
Answer accepted

Hello Raisa,

Z4J did add the ability to 'clone test steps' within an existing test case. That works for us when modifying existing test cases as new features/capabilities are added and test cases need to be updated.

However, I have not seen the capability to 'copy' an entire test step (with all three fields - step, data, results) and then 'paste' it into an entirely separate test case.

Our process for copying complete test steps into an entirely new test case is:

  • Open an existing test case in one tab
  • Open a new test case in another tab
  • Then for each field in the existing test step, respectively
    • Used 'Select All' (control + A), 'Copy' (control + C)
    • And then in the new test case step... 'Pasted' (control + v) the field data

It may be a few extra steps of clicking between tabs and select/copy/pasting... but it works for now until some new feature is added to do the same thing more efficiently.

Hi All

We are glad to inform you that this feature of "Copy Test Steps from one Testcase to multiple Testcases across Projects manually and using JQL" has been included in the May update of Zephyr for Jira cloud.

https://zephyrdocs.atlassian.net/wiki/display/ZFJCLOUD/All+Release+Notes

Please check the link below and access the feature in your Zephyr for Jira Cloud instance

https://zephyrdocs.atlassian.net/wiki/display/ZFJCLOUD/Copy+All+Test+Steps+between+Test+Issues

Thanks

ZephyrSupport

Hello, 

I have tried to use this functionality, however it just starts "Processing" and continues for 6+ minutes and does not stop.

The test I am copying from only has 3 steps and what could possibly be breaking it is that one step does not require test data, so that field is blank.

 

Thanks,

Ken

I have tried this option. It is being worked proper but it has been copied all test steps.

Is there any way to copy only selected steps to another test cases?

Like Meghana srimathi likes this

this buys me nothing.  Why dont you have shared test steps?  I've seen posts from 2013 requesting this feature.  

 

This is an enormous product gap.  Copy test steps is only 10% of the battle.  If I have 100 tests and I need to change the way someone logs in to a website, for example, then i have to go to 100 tests and update them manually.  Sorry that's a show stopper for out team.  

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Marketplace Apps & Integrations

Join our Webinar: 5 use cases to supercharge Jira with apps

G’day Atlassian Community! We’re excited to announce that we’ll be doing a new webinar on 5 use cases to supercharge Jira Cloud. The Atlassian Marketplace offers customers thousands of apps and int...

99 views 1 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you