It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Connecting to my GitHub organization only shows the public repos

Lara Fields Jul 10, 2012

After setting up OAuth, connecting to the GitHub organization (containing our "golden" repositories), only shows the public repositories. Connecting to a specific user in the organization will show any private forks of those same repositories, so the OAuth is working properly, but the actual master repositories are not shown (only the forks). This is (according to the plugin manager) the lastest version of the DVCS plugin. It lists the version as "1.0"

14 answers

1 accepted

3 votes
Answer accepted

Hi,

This issue is now fixed in 1.0.3. Available on marketplace.

Thanks everyone for reporting and commenting.

Dusan

Andrew Karakotov Jul 26, 2012

Dusan, hi!

Updated plugin to 1.0.3 and got no change - no private repos from our organization github account.

Hi Andrew,

There is a scheduler job that refreshes list of repositories every hour. You can also trigger it from account dropdown menu "Refresh List".

If refresh doesn't help try to remove and readd the organisation.

Hope this helps
Cheers
Dusan

Andrew Karakotov Aug 01, 2012

Nothing worked so I tried everything from the beginning: deleted Github OAuth settings, deleted applications from our Github organization and created new app again there, updated Github OAuth settings in JIRA. Then I tried to link my org github account on Manage DVCS Accounts page (it redirects me to github site where I confirmed about the access) - and now I've got

Error!

Error obtain access token. Please check your credentials.

What am I doing wrong?

Filip Dec 03, 2018

It happened to me after I deleted BitBucket integration - all private Github reports disappeared. I had to delete and re-add integration to make it work. 

2 votes
Earth Warren Jul 12, 2012

We are having a similar issue. I can see all of our public repos but none of the private.

2 votes
Jason Edwards Jul 17, 2012

I'm also seeing this issue, can't view any private repos. Nothing showing in the Jira log file either ...

1 vote
Kega Webshop Jul 15, 2012

I have the same problem, I am a member of a team with private repos, those I can't see in Jira, when I make a public repo with my user it comes immediately.

How can this be fixed so I can see all 30 private repos in Jira?

1 vote
Ben Knight Jul 18, 2012

Bump Seeing this issue as well, even after upgrading to v 1.0.1

1 vote
Dominic Bräunlein Jul 18, 2012

Same issue here.

1 vote
Andrew Karakotov Jul 18, 2012

The same problem. And we can't use deprecated github plugin because it's not compatible with JIRA 5.x.

1 vote
Kega Webshop Jul 18, 2012

Tried the update....no change

1 vote
Michael Goodnow Jul 18, 2012

Recommend everyone go to the bug Lara Fields created and vote for it. :)

0 votes
Lara Fields Jul 18, 2012
0 votes
Kega Webshop Jul 26, 2012

Damn, for a minute I hoped it would be solved but still no repos :-(

Lara Fields Jul 26, 2012

I am the original poster, and it works properly for me now with v1.0.3 - all private repos are showing.

0 votes
Kega Webshop Aug 01, 2012

Perhaps you can explain all of us then what we are doing wrong?

I know that we are running Jira 5.06

0 votes
Martin Martin Aug 02, 2012

Hi,

We are always displaying repositories visible for the user/team filled in the 'Team or User Account'.

If you fill your user account in the 'Team or User Account' field, the plugin will display all repositories owned by the user, not the team. If you need to see repositories from the team account, fill the team account instead of user account. And of course you have to have rights to see the private repositories in your team.

Can you verify if this works, or you still have problems?

Thanks everyone interested in the DVCS plugin.

Martin

0 votes
Kega Webshop Aug 12, 2012

It now also works for me :-)

I did the following steps:

- Went to GitHub OAuth Settings and pressed "Add/Update Keys"

- Went to Manage DVCS Accounts, removed the old account, added a new account and used the company group (instead of the team that I used first) and then all repos showed up..

Maybe it's nothing special that I did, but perhaps I'm helping someone else with it. :-)

Thanks for the new version!

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Marketplace Apps & Integrations

Join our webinar: “Asset Management: The Role of Context in ITSM” with Atlassian & Riada

  Hi Atlassian Community! This is Teresa from the Jira Service Desk team. On June 19th, I’ll be hosting a webinar “Asset Management: The Role of Context in ITSM” with Atlassian Partne...

263 views 2 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you