Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Connect external database jira plugin

Hello guys,

I have a big problem.

I'm using Active Objects in my application. With Active Objects I'm using jira database. I don't have problem with AO, It's working well.

But in my jira I need to get informations from another database (Oracle).

I put in my pom.xml:

<dependency>
     <groupId>jdbc</groupId>
     <artifactId>jdbc-oracle</artifactId>
     <version>11.1.0.7</version>
</dependency>

When I put this, my plugin stop to work and I have this error:

Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle (CLASS_PLUGIN) [185]: Unable to resolve 185.0: missing requirement [185.0] osgi.wiring.package; (osgi.wiring.package=com.sun.security.auth.module)

When I change to:

<dependency>
     <groupId>jdbc</groupId>
     <artifactId>jdbc-oracle</artifactId>
     <version>11.1.0.7</version>
     <scope>provided</scope>
</dependency>

I don't have any error but when I run my code:

Class.forName("oracle.jdbc.driver.OracleDriver");

I have:

java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver not found by ... [166]

What can I do to fix this problem ?

thanks

3 answers

0 votes
Andy Heinzer Atlassian Team Jul 18, 2017

Natively JIRA supports connections to Oracle databases (for storing JIRA data).  However with JIRA 7, it only supports Oracle 12c.  As such our installation packages are actually shipping an existing jdbc driver.   I think this file is in the install folder/lib and tends to be named ojdbc7.jar or something alike.  I think you might still be able to use this 12 driver for connecting to an 11 database, but I'm not sure.   

I did notice that in the JIRA dbconfig.xml if you configure JIRA to use Oracle as the database that stores JIRA data, the format of the dbconfig lists the driver-class value as "oracle.jdbc.OracleDriver".   But I see in your code it is listed as "oracle.jdbc.driver.OracleDriver".   Try changing the class name to match my example and see if that works.

do you have exactly dependency in your pom where could send me ?

@leandro siciliano

Hey Leandro, 

I am experiencing issues as you. Did you manager to find a solution?

Still the same issue. Trying for jira server 8.5.1 with

<dependency>
<groupId>com.oracle.jdbc</groupId>
<artifactId>ojdbc8</artifactId>
<version>12.2.0.1</version>
</dependency>

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Happy New Year and Welcome New Marketplace Partner Program Partners!

Happy New Year! We hope you all had a safe and restful holiday season. 2020 was a unique year full of unforeseen events; however, as we enter the new year of 2021, we’re optimistic for the light at t...

810 views 7 24
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you