Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,207
Community Members
 
Community Events
176
Community Groups

Cannot automate setting field "Original Estimate"

When I try to do this the audit log describes the error with:

"Unknown fields set during create, they may be unavailable for the project/type. Check your custom field configuration. Fields ignored -Time tracking (timetracking)"

So I think I need to set permissions right some where. 
But what confuses me is, that the "Original Estimate" field does not exist in the "Custom Fields" menu, nor does "Time Tracking".

Also when I view the task that I have created with automation I can easily edit the Original Estimate field manually which heavily puzzles me vs then getting the information that the automation doesn't have permission.

See here, this is the field I want to edit with automation just like I do with other fields such as "Labels", but I can't even though I can easily change it manually:

 

image.png


Help would be super appreciated!

3 answers

1 accepted

0 votes
Answer accepted

Wow I just solved it but I would kind of consider it a Jira bug, solution was to set original estimate after the subtask was created instead of when it was created, that seems very unintuitive and the audit log does a poor job describing why this work around is needed with the permission hints.

See solution here:

image.png

Did this really fix the issue? My Original Issue has a Original Estimate set to 2h. When I setup this automation it clones the other fields from the Original Issue just fine. Only issue is that the Original Estimate in the clone is always set to 0h instead of 2h. Any idea why this would happen?

I have confirmed that this fixes the issue. The key was to configure the Edit issue step to (Copy Original Estimate from Trigger issue.)

0 votes
Daniel Ebers Community Leader Jul 22, 2021

Hi @Stef Green

could you probably show you rule alongside with the log? This makes it sometimes easier for Community members to follow.

One wild guess: have you checked if the executing user of the rule has indeed the "Work on issues" permission in your project?

I found it in documentation about time tracking (https://support.atlassian.com/jira-cloud-administration/docs/configure-time-tracking/) it seems to be needed.

Cheers,
Daniel

Thanks yes let me give you a bunch of screenshots here:

This is the audit log on the rule and red marked the error and the rule that spawns the error here:

image.png

 

This is how I set Original Estimate when I create the new sub task, note that I've also tried with syntax 2d, which caused no difference:
image.png

Also have permission on, not sure if I can grant more broad permission than this, also my account is admin and I'm the owner of the rule:
image.png

0 votes
Joy Chiu Atlassian Team Jul 20, 2021

Hi @Stef Green 

According to the message in the audit log, it is possible that the custom fields are not enabled in that particular issue type. Maybe you can check what type of issue will be created in the rule and check that config of the issue type.

Cheer,

Joy [Automation for Jira]

Thanks, to clarify the issue it creates is a Sub-task which uses the default issue type scheme which includes Time Tracking.
And I believe Time Tracking is what enables the "Original Estimate" field, but that part is super confusing, cause  normally fields exist by themselves, but the "Original Estimate" field does not, it's just shown in connection with Time Tracking.
image.png

Joy Chiu Atlassian Team Jul 22, 2021

Hi @Stef Green 

Can you try to create a subtask to see if you can set Original Estimate field when creating? Or share a screenshot with us about your configuration. And here is a reference about change the time tracking: https://community.atlassian.com/t5/Jira-Core-Server-questions/How-to-change-timespent-with-an-automation-rule/qaq-p/401843

 

Cheers,

Joy [Automation for Jira]

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events