Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation "Send web request" component - webhook body custom data panel is locked/uneditable?

Re: Automation for Jira (on cloud)

When adding a new "Send web request" component - I'm trying to put own custom data into the webhook panel.

But the "Custom data*" field isn't available (i.e. can't add or edit panel & it's grayed out).

Any one got any ideas?

 

 

 

6 answers

Hi,

Today, it looks like this issue is no longer happening for me - 'custom box' is now editable.

Although there's no change in their support ticket - but I guess someone's done something.

Also, someone has helpfully added a very simple workaround for anyone like me who'd be stuck in the interim waiting for Atlassian to resolve this bug - as also included below:

---

daniel.szewczyk added a comment - 3 days ago 

The workaround is to use Inspect tool in your browser, find disabled field and remove 'disabled' flag from the HTML definition of this field:
<textarea rows="10" class="textarea long-field long-field" name="customBody" id="customBody" disabled="">

Field will become disabled again as soon as you start typing anything in this field, so the best way around is to copy-paste the content from a text editor/ notepad when you enable it again.

Atlassian have now replied saying that after further investigating this issue - it turns out that this issue is a recently discovered bug on their side. They're already tracking this, and you can access it here.

Can not edit custom payload for webhook in automation rules JRACLOUD-75639

https://jira.atlassian.com/browse/JRACLOUD-75639

Hi,

Many thanks to those who've replied.  This issue is still present. 

Thus, I've logged a support ticket with Atlassian.

I'll add any feedback received onto this post for information.

Thanks.

We are having the same issue as well, it worked last week but not today.

I'm having the same issue. This worked fine for me in the past (a couple of weeks ago) : I was able to create automations with action "Send Web request" and with custom data. I had no issues at that time.

Today, I've been trying to update custom data for one of those automations I created, but the field is uneditable as @Tim C mentioned. This happens both for editing an exisiting automation or while creating a new one.

I believe this needs to be escalated to Atlassian support.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

🍻🍂Apptoberfest Update: Upcoming Virtual Events 🎉

Hello Community! I hope you've been enjoying the 🍂Apptoberfestivities🍂 (I know I have!) The event is heating up next week with a series of virtual events that we're calling the 🍻🍂Partner App ...

107 views 1 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you