Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation - Subtasks won't pick up Parent information (Next Gen Cloud) Edited

Context: We're using subtasks for "bugs" when a Story didn't meet its acceptance criteria and I want to be able to move the parent story from "In QA" to "To-Do" when a new subtask is created, and I want that subtask to take info like assignee from the parent.

I feel like I've tried this a million and one ways. Everything I do fails because "There's no parent." I wrote a simple bit of JQL it has to pass to verify that the parent field is not empty. It passes that, then still thinks there's no associated parent to pull data from.

Any help appreciated.Screenshot (90).png

2 answers

1 accepted

0 votes
Answer accepted
Daniel Eads Atlassian Team Apr 28, 2020

Hi Jess,

Unfortunately this is a known behavior with Automation and Next Gen projects. Our development team is aware of the problem and will be addressing it soon. You can follow along with the progress here: AUT-1297 

Cheers,
Daniel | Atlassian Team

There doesn't appear to be a way for me to mark myself as a watcher on that ticket =\

But thanks Daniel! I'm going to be doing a lot of automating for my next gen cloud project, so I'm sure you'll see me pop up again.

Hi @Daniel Eads ,

I've just check the AUT-1297 it seems to be fixed but I'm still facing exactly the same issue. 

Daniel Eads Atlassian Team Aug 05, 2020

Hi @onur - I'd recommend opening a case with our support team at support.atlassian.com/contact so we can take a look at the logs for your site and see if something's amiss. Please include the name of the rule you're seeing this issue on when creating the support case. Thanks!

0 votes
Mikael Sandberg Community Leader Apr 24, 2020

Hi @Jess H.,

Welcome to Atlassian Community.

Have you tried using an Edit issue action and set the assignee to copy from parent?

Screen Shot 2020-04-24 at 1.38.33 PM.png 

Mikael Sandberg Community Leader Apr 24, 2020

Also, have you tried checking the issue type is set to sub task by using the Issue field condition instead of using the JQL?

Hey thanks Mikael, I've tried both of those to no avail. It's saying its successful, but not grabbing the parent assignee in either case:

Screenshot (91).pngScreenshot (92).pngScreenshot (93).png

Just to be triple sure, I checked the parent and it does have an assignee ;)

Mikael Sandberg Community Leader Apr 24, 2020

Odd, I just created the same rule on my end and it successfully copied the assignee. If you look at the history (click the down arrow next to Comments under Activity) for the sub task, do you see an entry where Automation sets the assignee? 

Does it matter that I'm in Jira Cloud? Here's the history log.

Screenshot (94).png

Mikael Sandberg Community Leader Apr 24, 2020

Okay, that looks a bit different than mine, I'm on Cloud too.

Screen Shot 2020-04-24 at 3.27.51 PM.png

Okay, so I think it is because you are using a next-gen project, I just tested it and get the changed the Parent instead of the updated the Parent entry in the history, and the automation rule is not copying the Assignee. Let me get someone from Atlassian to take a look at it.

Like # people like this

Hi,

@Mikael Sandberg @Daniel Eads 

Though the issue was resolved. It seems like the problem continues to persist. Is there another possible reason for the "Copy from Parent" not working?

Automation:

- Trigger: Creation of Issue

- Condition: Created Issue equal Subtasks

- Action: Copy Label From Parent

Test:

- Click "+" to add subtask in a Parent Issue. (This is where I think the problem is as Subtasks created via this method might have the Parent added only after it is created?)

Screenshot 2020-10-15 at 9.38.52 AM.png

Outcome:

Success -> Audit Log -> "Can't find issue to copy from labels"

Screenshot 2020-10-15 at 9.35.21 AM.png

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

5 mobile apps for Jira Cloud to boost productivity

  It’s very important to have access to the workflow process from anywhere. Especially if you manage the work of others. There is no difference whether you’re out of office, or drive a ca...

284 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you