Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Atlassian Marketplace server is not reachable

I recently downloaded and installed JIRA 5.1.3.

On my first attempt to use UPM to install a new plugin I got the error message: "Atlassian Marketplace server is not reachable" (And, of course, no Plugins are visible at all on the page.)

I am the JIRA admin but not the Administrator on the Server (Windows). I believe it is behind a quite restrictive firewall. However, from a web browser on the server I am able to successfully navigate to Ping is disabled and Traceroute is not installed. (Like I said, they are quite restrictive around here.)

I see no informative information about this issue in atlassian-jira.log.

I have submitted a ticket to my company's Cyber Security department, to see if they can help me. But they have no experience with Atlassian products at all, so I would like to find out from this forum what information they might need to pinpoint the problem.

6 answers

2 votes
DanielP Rising Star Dec 11, 2012


We had similar problems. We solved it by adding the marketplace ssl certificates to our keystore.

This is a step by step for Linux, you should be able to google the corresponding commands for your Windows server version:

cd /path/to/your/keystore

openssl s_client -connect >


openssl s_client -connect >



# Delete everything before the "BEGIN CERTIFICATE" line and everything after the "END CERTIFICATE" line

keytool -import -alias -keystore your-keystore-file-name -file

keytool -import -alias -keystore your-keystore-file-name -file

Hope this helps.


Found another link that might be useful.


I have the same problem after upgrading my Jira production server from 4.4.4 to 5.2.5 version. No problem after upgrading the test server !

I wish to try the procedure described in this answer but where is "cd /path/to/your/keystore" on a Linux server ? Is it in Jira installation directory ?


It was caused by a security config on our networks. Production server is on DMZ and ssl protocol was blocked.

Problem solved for me.

How did you configure your SSL for JIRA? Check the server.xml and it will tell you that path of the keystore you used. By default the keystore is at the user (which runs JIRA) home directory (.keystore file)

In that case, I trust this is related to this bug that has been filed already by Yilin Mo. ;-)

Feel free to check it yourself if you like and vote on it also.



0 votes

Many Thanks to all!

I've created a KB based on all your answers, feel free to comment and share:




0 votes

Hi Kevin,

Can you tell me if you are using the latest UPM version, please?

If not, can you try upgrading and see what you get?


I am getting the exact same problem.

JIRA = v5.2.0
UPM = v2.7.10 (had to upgrade manually and restart the JIRA service)

The log has an interesting exception: value failed: missing required JSON property: expertDiscountOptOut

2012-12-12 12:52:17,988 http-bio-8080-exec-1 WARN xxxx 772x298x2 8g1c8y aaa.bbb.ccc.ddd, /rest/plugins/1.0/available/featured [] Failed to get featured plugins
com.atlassian.marketplace.client.MpacException$InvalidResponseError: Instantiation of [simple type, class com.atlassian.marketplace.client.model.Pricing] value failed: missing required JSON property: expertDiscountOptOut
	at com.atlassian.marketplace.client.impl.JsonEntityEncoding.decode(
	at com.atlassian.marketplace.client.impl.DefaultMarketplaceClient.decode(
	at com.atlassian.marketplace.client.impl.DefaultMarketplaceClient.getEntity(
	at com.atlassian.marketplace.client.impl.PluginsImpl.getMorePlugins(

I'm running 2.7.3, but based on the previous comment, it sounds like the problem persists with the latest UPM.

0 votes

Hi, I believe this is a bug with JIRA 5.1.3. I've already seen quite a few users here with the same result. Once they moved back to JIRA 5.1.2 it has worked.

Thanks, Harry, but I'm hesitant to downgrade. It seems like a fairly invasive change for such a small issue, and I don't see any indication in the 5.1.3 release notes suggesting any modifications were made in that section of code. But I will take your suggestion under consideration. Thanks.

Thanks, but the documentation is insufficient. I have opened a Support Ticket to try to get to the bottom of this. [JSP-138684 ]

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events