Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Are you able to delete test cases in TM4J?

Hi,

The documentation states that Test Cases can be deleted but I only have an "Archive" option. 

I used to be able to delete test cases, has anything changed recently?

12 answers

1 accepted

1 vote
Answer accepted

FWIW, the TM4J document states that the Delete function has been removed temporarily but will return later.

https://www.adaptavist.com/doco/display/KT/Deleting+Test+Cases

Last updated 19 August 2019.

Ah, yes. So maybe it will come back sometime soon. Thanks

I really would applaude getting back the possibility to delete testcases in cloud version...

Hello! has anyone seen an update on this lately? Would be nice to have the ability to delete test cases back. 

@Thiago Ribeiro _Adaptavist_ Any idea when the delete option for testcases will be added? Thank you!

Our team has no issue with deleting test cases, we are on version 6.5.2

Can you see what your permissions are in Jira?  Maybe they have changed

permissions.JPG

Hi Felicia,

We have the Delete option in permissions but when viewing the "Tests" board and selecting tests there is no DELETE button anymore, only ARCHIVE:

Tests board_no delete.jpg

Same issue here, only the archive option is visible in the permissions

Dang.  That's annoying.  I see the delete button where you see the Archive button.  I'm on TM4J Server version 6.6 on Jira 7.13.1.   

Did you submit a bug to Adaptavist?  They might have some idea about what is going on.  

I'm on Jira Cloud and TM4J cloud version 1.0.27-AC.

I haven't raised a bug yet, wanted to check with the community first. Thanks

Hi Guys has this been resolved?

It's permission related,(Mine is resolved). 

I just re-checked permissions and we don't have a DELETE option for Test Cases anymore:
Test_Management_JIRA.png

Like Veronika S_ likes this

I couldn't see "DELETE" either but it is visible on the "Permissions" page of the Project Creator.

It has to be configured from Whoever created the Project.

Ah, you mean in the actual Project settings?

Project permissions.png

Well, I have now lost the ability to delete test cases, too.  Pretty sure it coincided with the updated to 6.7.2 for the security hotfix.   Archive is the only option.   

I confirm that we have exactly the same problem in our end. Delete is not present, and this is annoying as hell. No way to fix it, even while playing with the project settings. Only archive is there, which is useless for us.

Is it possible to estimate the come back of the delete option for test cases in the cloud version? Archiving something and throwing something (broken or unfinished) away are very different things ...

Hey I was also having this problem, but I have just discovered a workaround - by deleting folders, you can delete all the test cases within. It's kinda slow if you want to do just one, but I had imported a whole bunch of duplicates... Hope this helps!!

Last time I tried that, it was the illusion of deleting them. When I checked, they were sent in the archives, but without any folder structure. Maybe it changed. On my end, we went for another testplanning solution instead.

I don't know - it worked for me, those cases are not in the archives. I guess we'll see if they pop up later. Thanks for the heads-up though.

Workaround did not work for me. The test case in the deleted folder was just orphaned. I can still find it by using the "All Test Cases" option at the top of the Folders menu. Seems 100% functional also; was able to modify, put in a new folder, etc. 🤷‍♂️

Like marcelo.lucio likes this

It appears that the Delete feature has been removed. Can only archive test cases. I don't know why they decided to do that when it's a frequently used feature.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

5 mobile apps for Jira Cloud to boost productivity

  It’s very important to have access to the workflow process from anywhere. Especially if you manage the work of others. There is no difference whether you’re out of office, or drive a ca...

249 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you