Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,412,030
Community Members
 
Community Events
169
Community Groups

Advanced copy field value from epic to task

Hi everyone,

I have the below automation working in several of our projects.

Screenshot 2022-11-24 at 4.33.52 PM.png

The requirement is to add one more field to this automation which is not present in the dropdown menu. It says to use the More Options where I tried to figure out what I need to write but I failed. I found this example online

{
      "edit": {
        "customfield_id": [
           {{#triggerIssue.customfield_id}}
               {"add": {"value": "{{value}}"}}{{^last}},{{/}}
           {{/}}
       ]
     }
}

and tried it but I am getting the following from the audit log:

 

Screenshot 2022-11-24 at 4.40.25 PM.png

I don't know if it matters but the field that I trying to include is locked. 

Help?

 

1 answer

0 votes
John Funk Community Leader Nov 24, 2022

Hi Anastasia,

It sounds like they field is not available - which would explain why it is not in the dropdown as well. Check the Context for the custom field to be sure it includes the project you are working with in this rule. If it is, check to see if it is on the Create screen for that project. 

Hi @John Funk

It is a locked field and it says:

Screenshot 2022-11-24 at 5.46.57 PM.png

It is associated with my screens and I can see it in all the projects.

Screenshot 2022-11-24 at 5.45.26 PM.png

John Funk Community Leader Nov 24, 2022

Okay - thanks for sharing that. What type of project are you using? Team-managed? Company-managed? Jira Work Management?

It is a company-managed project.

John Funk Community Leader Nov 24, 2022

Very good - see the other posts - not looking good right now. 

Like Anastasia Seidaridi likes this

I tested it with other fields that work for sure and I am getting the same result. 

I think the json is wrong. 

John Funk Community Leader Nov 24, 2022

Can you share the actual json that you have?

{
"edit": {
"customFieldId_10001": [
{{#triggerIssue.customFieldId_10001}}
{"add": {"value": "{{value}}"}}{{^last}},{{/}}
{{/}}
]
}
}

 

I am really not literal with json so I wouldn't find a mistake

John Funk Community Leader Nov 24, 2022

Should be customField_10001 not customFieldID_100001

Sorry John, 

I can't see what do you mean. Both of them are customFieldId_10001. I copy-pasted the value from the field's info.

John Funk Community Leader Nov 24, 2022

You do not need the letters ID in there.

Like Anastasia Seidaridi likes this

Oh, I see now, I thought the extra 0 was the issue. I just tried it and unfortunately got the same result.

Screenshot 2022-11-24 at 7.13.31 PM.png

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events