wrong JVM version JIRA software 7.0.2 & 7.1.0 when config.bat is run

Hi,

I've installed JIRA software 7.0.2 & 7.1.0 on  Windows 7 and Windows 2008 R2.

(that is, installed 7.0.2 then tried the below, removed 7.0.2 and installed 7.1.0 and tried the below)

I need to connect to an existing database - upgrading production system here from 6.4.1

 

Install works, but when I stop_service and run config.bat from %JIRAhome%\bin\ it insists

*******************************************************************************

*******      Wrong JVM version! JIRA requires at least 1.8 to run.      *******

*******************************************************************************

This is the same error if no java is installed other than the what is in C:\Atlassian\JIRA\jre

or if I move the install to C:\Program Files\Atlassian\JIRA\jre

or if I change setenv.bat

or if I change catalina.bat

or if I change the java home in the system advanced in Windows and install a Java 8u73 and point the setenv and catalina bat's at that.

 

Any hints on how to make this work? I'm continuing to try suggestions from various forums.

---------------------------------------------------------------------------------------

Here's part of the info requested

Here's from the system, figuring out how to get it during startup.

C:\>echo %JAVA_HOME%

C:\Program Files\Java\jre1.8.0_73

 

C:\>Java -version

java version "1.8.0_73"

Java(TM) SE Runtime Environment (build 1.8.0_73-b02)

Java HotSpot(TM) 64-Bit Server VM (build 25.73-b02, mixed mode)

 

C:\>for %i in (java.exe) do @echo %~$PATH:i

C:\Program Files\Java\jre1.8.0_73\bin\java.exe

 

Atlassian JRE is on the data drive:

D:\Atlassian\JIRA\jre\

Catalina log

19-Feb-2016 11:27:52.636 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log JAVA_HOME:             D:\Atlassian\JIRA\jre

2 answers

1 accepted

This widget could not be displayed.

Can you print out the java version and java locations during startup to debug where it's getting it from?

Answer was:

stripping out every reference to Java other than the Atlassian installed JRE then

 adding a validation query to  dbconfig.xml and restarting Jira

<validation-query>select 1</validation-query>
then ensuring licensing (due to recent switch) serial numbers were all in order was the fix.
Thanks for pointing me in the right direction.
This widget could not be displayed.

Hi, I experienced the same trouble.

For me this just the message that is misleading.

Actually as we also have a confluence instance installed on the same machine, I check the JAVA_HOME variable declared : c:\WhatEver\...\jdk.

This rang bell : I had same kind of issue with confluence installation but the message clear : "You must point to a JDK not a JRE"...

Therefore I changed the path of JAVA_HOME, accordingly in the setevn.bat for JIRA instance... Et voilà !

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

50 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you