statuses not showing up in column management (JIRA AGILE)

We use JIRA 6.3.5 with Agile Version: 6.6.0

We use not the Simple Agile Workflow because we need more columns as the one from Simple Workflow. I can not say when this started but I think it must be in connection with latest update of JIRA or Agile. Some statuses are not showing up in the column management.

We have for an example a status called In QA Review and all issues in this status are not in the particular board. Neither show they up on plan mode nor work mode. The filter which is used for the board is correct:

  • status in ("Ready to Implement", "In Development", Reopened, "In Technical Review", "In QA Review") AND project not in (XXX, XXX, XXX)

As you can see in the image there is no status In QA Review displayed.

Bildschirmfoto 2014-10-08 um 00.37.58.png

Other boards show an explanation mark behind some statuses although configuration must be correct. When the status is moved away by drag and drop it will disappear like described in above case.

 

Bildschirmfoto 2014-10-08 um 00.39.58.png

Can someone help?

4 answers

This widget could not be displayed.

@Nic Brough [Adaptavist]'s answer gave me the starting point to resolve this issue for me. I simplified the board filter enough to make JIRA recognise the new statuses (project = ABC ORDER BY Rank ASC), mapped the statuses to the relevant columns, then put the filter back to it's original value.

Note that those columns now complain in the configuration that they contain statuses not supported by the filter, but this is incorrect - apart from the warning triangle on those statuses in the column list, everything now works as expected for me smile

I hope this helps someone else!

Thank you very much. Your comment saved me today :-)

Thank you, updating filter back and forth did the trick. 

Perfect... solved my problem.

Thanks! This trick of updating the filter back to original and mapping the status and then finally pasting the current filter works. Weird, but works, but the warning wouldn't go away (even though everything works as expected).

For anybody interested, this Atlassian bug report looks like the same issue. https://jira.atlassian.com/browse/JSWSERVER-11623

They suggest adding the following to your board filter as a workaround.

"AND issuetype in (standardIssueTypes(),subTaskIssueTypes())

I got the status to appear, it gives me the "yellow hazard triangle", but i can not move anything into the status.  Any other suggestions?

False alarm.  Everyone go back to work...

 

This widget could not be displayed.

Start by simplifying the board filter.  Drop the "status in" clause to begin with and then refresh the config.  

Are you 100% sure that all the projects that are "not in (xxx, yyy, zzz)" are using workflows that include the "In QA review" status?

This widget could not be displayed.

Hi Nic

Thank you for your answer.

We have different schemes and many workflows. So lets take only one Project to make it more easy to troubleshoot. We have one scheme and in that scheme one project is assigned. Within that scheme we have two different workflows.

The filter to show issues for agile board is following:

  • status in ("Ready to Implement", "In Development", Reopened, "In Technical Review", "In QA Review", Resolved, Deployed) AND priority != blocker AND project = pc OR project = PC AND issuetype = Epic AND status not in (Closed, Resolved) ORDER BY Rank ASC

The column management for that board (for that project) looks as following.

Bildschirmfoto 2014-10-08 um 00-1.39.58.png


We have two workflows in order to separate development issues from operation issues. Issue type Task for example will not show up in the scrum agile board. Those issues only show up in the kanban agile board. You can see on the above image that some statuses have an explanation mark and for example the status "deployed" does not show up at all.


So coming back to your question if all projects (in this case only one project) are using workflows that include the status "deployed" in this particular case. The answer is no. The workflow 1 has status deployed as we use it for development. The workflow 2 does not have it as we use it for issue type task but we do filter those issue types to not show up in the scrum agile board. This worked before and we did not have any issue sad

BTW I removed the status in from filter. Saved it and went to configure board but nothing happened. I changed it back how it was and went again to configure board but same as before


This widget could not be displayed.

Anyone who can help here?

i.e. status "In QA Review" is not displayed in scrum agile board under column management. current filter is:

status in ("Ready to Implement", "In Development", Reopened, "In Technical Review", "In QA Review") AND project in ("XXX", "XXX") OR status in (Open, "In Development", "In Technical Review", Reopened) AND issuetype = "Technical task" AND project in ("XXX", "XXX") OR status = "Ready to Implement" AND issuetype = epic AND project in ("XXX", "XXX") ORDER BY Rank ASC


Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

255 views 5 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you