setting up integratedSecurity in dbconfig.xml

upgrading from 4.0.1 to 4.4 can't get connection to work.

I have two JIRA services running as ants\svc_cc_jira_dev

Version 4.0.1 uses standard tomcat configs to set up a connection and it works

<Resource name="jdbc/JiraDS" auth="Container" type="javax.sql.DataSource"

driverClassName="net.sourceforge.jtds.jdbc.Driver" domain="ants"

url="jdbc:jtds:sqlserver://gblondb018:1513/ccjiradb;tds=8.0;lastupdatecount=true;integratedSecurity=true" />

Version 4.4 uses its own config and I get the error

“The login is from an untrusted domain and cannot be used with Windows authentication.”

<jira-database-config>

<name>JiraDS</name>

<delegator-name>default</delegator-name>

<database-type>mssql</database-type>

<schema-name>ccjiradb</schema-name>

<jdbc-datasource>

<url>jdbc:jtds:sqlserver://gblondb018:1513/ccjiradb;tds=8.0;lastupdatecount=true;integratedSecurity=true;domain=ants</url>

<driver-class>net.sourceforge.jtds.jdbc.Driver</driver-class>

<username>blah</username>

<password></password>

<pool-size>15</pool-size>

</jdbc-datasource>

</jira-database-config>

2 answers

1 accepted

2 votes
Accepted answer

I got integrated security working with JIRA v5.17 with a domain user.

I had to switch to MS JDBC:

  1. Downloaded sqljdbc_4.0.2206.100_enu.exe from Microsoft
  2. Copied sqljdbc4.jar to Atlassian\JIRA\lib and Atlassian\JIRA\atlassian-jira\WEB-INF\lib
  3. Copied x86\sqljdbc_auth.dll to Atlassian\JIRA\bin and Atlassian\JIRA\jre\bin and C:\Windows\System32
&lt;jira-database-config&gt;
  &lt;name&gt;defaultDS&lt;/name&gt;
  &lt;delegator-name&gt;default&lt;/delegator-name&gt;
  &lt;database-type&gt;mssql&lt;/database-type&gt;
  &lt;schema-name&gt;jira&lt;/schema-name&gt;
  &lt;jdbc-datasource&gt;
    &lt;url&gt;jdbc:sqlserver://server:1439;databaseName=APP_JIRA;integratedSecurity=true;domain=MYDOMAIN;&lt;/url&gt;
    &lt;driver-class&gt;com.microsoft.sqlserver.jdbc.SQLServerDriver&lt;/driver-class&gt;
    &lt;username&gt;MYDOMAIN\user&lt;/username&gt;
    &lt;password&gt;P@$$w0rD&lt;/password&gt;
    &lt;pool-size&gt;15&lt;/pool-size&gt;
    &lt;validation-query&gt;select 1&lt;/validation-query&gt;
  &lt;/jdbc-datasource&gt;
&lt;/jira-database-config&gt;

The extra paths I copied the jars/dlls to may be redundant, as too with the user/pass in the XML.

This looks promising

https://confluence.atlassian.com/pages/viewpage.action?pageId=262471708

it seems to have connected according to the logs

:-)

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,650 views 18 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you