run CLI in Jira

Hello, I have been unable to find an answer on this one. I have Run CLI in JIRA installed so that I can trigger a Bamboo build from a workflow transition. I have a bamboo plan that has spaces in it and I have been unable to get the build to run becuase of those spaces. I have tried "" and also % but those have not worked. If anyone has any insight into this I would greatly apprefiate it. Here is my CLI action - 

--action queueBuild --plan "JIRA Workflow Automation" %variable_Bamboo% %variable_Credentials%

 

I also tried renaming the bamboo plan without the spaces and then it does not recognize the plan. I have had success when just calling the build name but would like to use plan.

 

Thanks for the help.

--Wade

1 answer

1 accepted

The fix was to use the project-plan key pairing like JWA-EV.

 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

302 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you