run CLI in Jira

Hello, I have been unable to find an answer on this one. I have Run CLI in JIRA installed so that I can trigger a Bamboo build from a workflow transition. I have a bamboo plan that has spaces in it and I have been unable to get the build to run becuase of those spaces. I have tried "" and also % but those have not worked. If anyone has any insight into this I would greatly apprefiate it. Here is my CLI action - 

--action queueBuild --plan "JIRA Workflow Automation" %variable_Bamboo% %variable_Credentials%

 

I also tried renaming the bamboo plan without the spaces and then it does not recognize the plan. I have had success when just calling the build name but would like to use plan.

 

Thanks for the help.

--Wade

1 answer

1 accepted

The fix was to use the project-plan key pairing like JWA-EV.

 

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,811 views 11 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot